summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundationdevices.com>2023-09-20 12:05:25 +0200
committerLudovic Courtès <ludo@gnu.org>2023-09-28 00:05:50 +0200
commitab8290c06af242579c01c72219d11eea453c2dae (patch)
tree688e41fad392df4cc303d8d33bee413e52d20f35
parent8843e1e3163cb6779487525a1fb17f657148c72a (diff)
gnu: Add python-smbus.
* gnu/packages/linux.scm (python-smbus): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/linux.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 85e3d9845d..6eb7fb43b8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -75,6 +75,7 @@
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 dan <i@dan.games>
+;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -188,6 +189,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system meson)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module (guix build-system linux-module)
@@ -4963,6 +4965,29 @@ SMBus access.")
#~(list (string-append "prefix=" #$output)
(string-append "CC=" #$(cc-for-target))))))))
+(define-public python-smbus
+ (package
+ (inherit i2c-tools)
+ (name "python-smbus")
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f ;; No test suite.
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'change-directory
+ (lambda _ (chdir "py-smbus")))
+ (add-after 'change-directory 'set-library-path
+ (lambda _
+ (substitute* "setup.py"
+ (("-L\\.\\./lib")
+ (string-append "-L" #$(this-package-input "i2c-tools")
+ "/lib"))))))))
+ (inputs (list i2c-tools))
+ (synopsis "I2C/SMBus access for Python")
+ (description "This package provides a Python library to access
+@acronym{I2C, Inter-Integrated Circuit} and @acronym{SMBus, System
+Management Bus} devices on Linux.")))
+
(define-public xsensors
(package
(name "xsensors")