summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2023-12-02 17:18:12 +0300
committerLudovic Courtès <ludo@gnu.org>2023-12-10 22:26:58 +0100
commitad0c116508c2ff5e2e69d852ee5bb25202aae070 (patch)
tree2d52685dcceeddd4950e18b199fad1220166a6a6
parent17835e2e0d0603ef2be71da689d0299d8d4b8229 (diff)
gnu: guile-gitlab: Improve the package style.
* gnu/packages/guile-xyz.scm (guile-gitlab): Improve the package style. [inputs]: Remove input labels. Change-Id: I449a02e1f9d700f678bb09961b896dea1627632e Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/guile-xyz.scm64
1 files changed, 28 insertions, 36 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index a45ccd6111..fcaf788d37 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -5437,49 +5437,41 @@ high-level API for network management that uses rtnetlink.")
(commit (string-append "v" version))))
(file-name (string-append name "-" version))
(sha256
- (base32
- "0srkmchd4kmfa7q65r6fdzwklhgdlck1ll0s7smzs8ddjdgz2lwm"))))
+ (base32 "0srkmchd4kmfa7q65r6fdzwklhgdlck1ll0s7smzs8ddjdgz2lwm"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings
+ `(#:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings
#:modules (((guix build guile-build-system)
#:select (target-guile-effective-version))
,@%gnu-build-system-modules)
#:imported-modules ((guix build guile-build-system)
,@%gnu-build-system-modules)
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'wrap-program
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (guile-lib (assoc-ref inputs "guile-lib"))
- (json (assoc-ref inputs "guile-json"))
- (tls (assoc-ref inputs "guile-gnutls"))
- (version (target-guile-effective-version))
- (scm (string-append "/share/guile/site/"
- version))
- (go (string-append "/lib/guile/"
- version "/site-ccache")))
- (wrap-program (string-append bin "/gitlab-cli")
- `("GUILE_LOAD_PATH" prefix
- (,(string-append out scm)
- ,(string-append guile-lib scm)
- ,(string-append json scm)
- ,(string-append tls scm)))
- `("GUILE_LOAD_COMPILED_PATH" prefix
- (,(string-append out go)
- ,(string-append guile-lib go)
- ,(string-append json go)
- ,(string-append tls go))))))))))
- (native-inputs
- (list autoconf automake pkg-config texinfo))
- (inputs
- `(("bash" ,bash-minimal)
- ("guile" ,guile-2.2)
- ("guile-json" ,guile2.2-json)
- ("guile-lib" ,guile2.2-lib)
- ("guile-gnutls" ,guile2.2-gnutls)))
+ #:phases (modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (guile-lib (assoc-ref inputs "guile2.2-lib"))
+ (json (assoc-ref inputs "guile2.2-json"))
+ (tls (assoc-ref inputs "guile2.2-gnutls"))
+ (version (target-guile-effective-version))
+ (scm (string-append "/share/guile/site/" version))
+ (go (string-append "/lib/guile/" version
+ "/site-ccache")))
+ (wrap-program (string-append bin "/gitlab-cli")
+ `("GUILE_LOAD_PATH" prefix
+ (,(string-append out scm) ,(string-append
+ guile-lib scm)
+ ,(string-append json scm)
+ ,(string-append tls scm)))
+ `("GUILE_LOAD_COMPILED_PATH" prefix
+ (,(string-append out go) ,(string-append guile-lib
+ go)
+ ,(string-append json go)
+ ,(string-append tls go))))))))))
+ (native-inputs (list autoconf automake pkg-config texinfo))
+ (inputs (list bash-minimal guile-2.2 guile2.2-json guile2.2-lib
+ guile2.2-gnutls))
(home-page "https://github.com/artyom-poptsov/guile-gitlab")
(synopsis "Guile interface to GitLab")
(description