summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-19 21:48:17 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-19 21:48:17 +0100
commitad6c8887b4e98a282ee8180642861d0879955aa1 (patch)
tree96789fb033d41bd7002151cbff325e384757ea54
parentba3e25bbf217637d2054bb0c8b906f3eed230613 (diff)
gnu: emacs-flycheck-grammalecte: Update to 1.3.
* gnu/packages/emacs-xyz.scm (emacs-flycheck-grammalecte): Update to 1.3. [source]: Change upstream URL. [arguments]: Remove phase for symlinks since it is now possible to circumvent it with configuration. Configure accordingly. [home-page]: Update URL.
-rw-r--r--gnu/packages/emacs-xyz.scm43
1 files changed, 19 insertions, 24 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 29c09d1b9f..2ee35dbaa3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4666,18 +4666,19 @@ for Flow files.")
(define-public emacs-flycheck-grammalecte
(package
(name "emacs-flycheck-grammalecte")
- (version "1.2")
+ (version "1.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://git.deparis.io/"
- "flycheck-grammalecte/snapshot/"
- "flycheck-grammalecte-" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.umaneti.net/flycheck-grammalecte/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1mzmzyik843r4j0ibpwqrxmb0g4xmirrf3lxr010bddkmmxf749a"))))
+ (base32 "1f1gapvs9j89qr474103dqgsiyb96phlnsmq5hiv4ba242blg9lb"))))
(build-system emacs-build-system)
(arguments
- `(#:include '("\\.(el|py)$")
+ `(#:include (cons "\\.py$" %default-include)
#:exclude '("^test-profile.el$")
#:emacs ,emacs ;need libxml support
#:phases
@@ -4692,28 +4693,22 @@ for Flow files.")
(substitute* '("conjugueur.py" "flycheck-grammalecte.py")
(("/usr/bin/env python3?") python3))
#t)))
- (add-before 'build 'link-to-grammalecte
- ;; XXX: The Python part of the package requires grammalecte, but
- ;; the library is not specified in PYTHONPATH, since we're not
- ;; using Python build system. As a workaround, we symlink
- ;; grammalecte libraries here.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (grammalecte (assoc-ref inputs "grammalecte"))
- (version ,(version-major+minor (package-version python))))
- (with-directory-excursion
- (string-append out "/share/emacs/site-lisp")
- (symlink (string-append grammalecte "/lib/"
- "python" version "/site-packages/"
- "grammalecte")
- "grammalecte"))
- #t))))))
+ (add-after 'unpack 'specify-grammalecte-location
+ (lambda* (#:key inputs #:allow-other-keys)
+ (make-file-writable "flycheck-grammalecte.el")
+ (emacs-substitute-variables "flycheck-grammalecte.el"
+ ("flycheck-grammalecte--grammalecte-directory"
+ (string-append (assoc-ref inputs "grammalecte")
+ "/lib/python"
+ ,(version-major+minor (package-version python))
+ "/site-packages/grammalecte")))
+ #t)))))
(inputs
`(("grammalecte" ,grammalecte)
("python" ,python)))
(propagated-inputs
`(("emacs-flycheck" ,emacs-flycheck)))
- (home-page "https://git.deparis.io/flycheck-grammalecte/")
+ (home-page "https://git.umaneti.net/flycheck-grammalecte/")
(synopsis "Integrate Grammalecte with Flycheck")
(description
"Integrate the French grammar and typography checker Grammalecte with