summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-08-12 11:53:27 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-08-12 13:57:10 +0200
commitb07b4a7df2b87d376fdd570b0050d913999486e6 (patch)
treeb40f07c42d62310f8f414d8fffd80e19eb592737
parent44706254ff112d110b83f048ae2a8ede142b6f07 (diff)
gnu: Add r-tensor.
* gnu/packages/cran.scm (r-tensor): New variable.
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 54109cd5b4..c8325ad81c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22753,3 +22753,24 @@ and predictions of any machine learning model. Implemented methods are:
goodness-of-fit for continuous univariate distributions, using efficient
algorithms.")
(license license:gpl2+)))
+
+(define-public r-tensor
+ (package
+ (name "r-tensor")
+ (version "1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tensor" version))
+ (sha256
+ (base32
+ "19mfsgr6vz4lgwidm80i4yw0y1dr3n8i6qz7g4n2xa0k74zc5pp1"))))
+ (properties `((upstream-name . "tensor")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/tensor/")
+ (synopsis "Tensor product of arrays")
+ (description
+ "The tensor product of two arrays is notionally an outer product of the
+arrays collapsed in specific extents by summing along the appropriate
+diagonals. This package allows you to compute the tensor product of arrays.")
+ (license license:gpl2+)))