summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-11-20 15:43:35 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-11-20 17:08:06 +0100
commitb0e76b0828d6b1aee225e8268634547c33f9ba8d (patch)
treeab75a5db6f6506f71cb1e08e39774389ac952c93
parent0df82727a6e2ac2389d8e94aa66a641687bf4039 (diff)
gnu: ocaml-qcheck: Update to 0.18.
* gnu/packages/ocaml.scm (ocaml-qcheck): Update to 0.18. * gnu/packages/patches/ocaml-qcheck-fix-test-whitespace.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/ocaml.scm24
-rw-r--r--gnu/packages/patches/ocaml-qcheck-fix-test-whitespace.patch24
3 files changed, 46 insertions, 3 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a8540f6e12..2513530d0d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1533,6 +1533,7 @@ dist_patch_DATA = \
%D%/packages/patches/ocaml-dose3-Fix-for-ocaml-4.06.patch \
%D%/packages/patches/ocaml-dose3-dont-make-printconf.patch \
%D%/packages/patches/ocaml-dose3-Install-mli-cmx-etc.patch \
+ %D%/packages/patches/ocaml-qcheck-fix-test-whitespace.patch \
%D%/packages/patches/omake-fix-non-determinism.patch \
%D%/packages/patches/oneko-remove-nonfree-characters.patch \
%D%/packages/patches/onnx-optimizer-system-library.patch \
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 3db79032c4..ecd64ccf20 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1552,16 +1552,17 @@ archive(native) = \"frontc.cmxa\""))))
(define-public ocaml-qcheck
(package
(name "ocaml-qcheck")
- (version "0.12")
+ (version "0.18")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/c-cube/qcheck")
- (commit version)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
+ (patches (search-patches "ocaml-qcheck-fix-test-whitespace.patch"))
(sha256
- (base32 "1llnfynhlndwyjig7wrayjnds2b3mggp5lw20dwxhn2i2lkkb22m"))))
+ (base32 "1s652hrj2sxqj30dfl300zjvvqk3r62a1bnzqw1hqyf6pi88qn8x"))))
(build-system dune-build-system)
(arguments
`(#:test-target "."
@@ -1577,6 +1578,7 @@ archive(native) = \"frontc.cmxa\""))))
("ocaml-ounit" ,ocaml-ounit)))
(native-inputs
`(("ocamlbuild" ,ocamlbuild)))
+ (properties `((ocaml4.07-variant . ,(delay ocaml4.07-qcheck))))
(home-page "https://github.com/c-cube/qcheck")
(synopsis "QuickCheck inspired property-based testing for OCaml")
(description "QuickCheck inspired property-based testing for OCaml. This
@@ -1585,6 +1587,22 @@ generated instances of the type. It provides combinators for generating
instances and printing them.")
(license license:lgpl3+)))
+(define-public ocaml4.07-qcheck
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-qcheck)
+ (version "0.12")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/c-cube/qcheck")
+ (commit version)))
+ (file-name (git-file-name "ocaml-qcheck" version))
+ (sha256
+ (base32
+ "1llnfynhlndwyjig7wrayjnds2b3mggp5lw20dwxhn2i2lkkb22m"))))
+ (properties '()))))
+
(define-public ocaml-qtest
(package
(name "ocaml-qtest")
diff --git a/gnu/packages/patches/ocaml-qcheck-fix-test-whitespace.patch b/gnu/packages/patches/ocaml-qcheck-fix-test-whitespace.patch
new file mode 100644
index 0000000000..012f5de31c
--- /dev/null
+++ b/gnu/packages/patches/ocaml-qcheck-fix-test-whitespace.patch
@@ -0,0 +1,24 @@
+From 0cb666fffcbeb78c8c14d271b3ba65ea514bfc44 Mon Sep 17 00:00:00 2001
+From: Julien Lepiller <julien@lepiller.eu>
+Date: Fri, 19 Nov 2021 03:03:21 +0100
+Subject: [PATCH] Fix whitespace issue in test
+
+---
+ example/alcotest/output.txt.expected | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/example/alcotest/output.txt.expected b/example/alcotest/output.txt.expected
+index bde0b83..9f1417c 100644
+--- a/example/alcotest/output.txt.expected
++++ b/example/alcotest/output.txt.expected
+@@ -16,7 +16,6 @@ test `fail_sort_id` failed on ≥ 1 cases: [1; 0] (after 20 shrink steps)
+ [exception] test `fail_sort_id` failed on ≥ 1 cases: [1; 0] (after 20 shrink steps)
+
+
+-
+ ──────────────────────────────────────────────────────────────────────────────
+
+ 3 failures! 5 tests run.
+--
+2.33.1
+