summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2024-05-10 20:11:11 -0700
committerArun Isaac <arunisaac@systemreboot.net>2024-05-11 17:10:53 +0100
commitb23183c315fae08843a80441c60a8ddbb6590409 (patch)
tree2ed387b7249614ff78c0d5e22d68ef550d758170
parentdd007ed55ee7b792324e072f5ed3ddfcf561782e (diff)
gnu: Add guile-avatar.
* gnu/packages/guile-xyz.scm (guile-avatar): New variable. Change-Id: Ib255842ff8b59b7743c8d7be728a7ca7370024fe Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
-rw-r--r--gnu/packages/guile-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index dd56bffed9..24c216c696 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -49,6 +49,7 @@
;;; Copyright © 2023 Andrew Tropin <andrew@trop.in>
;;; Copyright © 2024 Ilya Chernyshov <ichernyshovvv@gmail.com>
;;; Copyright © 2024 Artyom Bologov <mail@aartaka.me>
+;;; Copyright © 2024 Felix Lechner <felix.lechner@lease-up.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -558,6 +559,33 @@ $(datadir)/guile/site/$(GUILE_EFFECTIVE_VERSION)\n"))
dictionary and suggesting spelling corrections.")
(license license:gpl3+)))
+(define-public guile-avatar
+ (let ((commit "c2860952fd09ecc878c3d4f1ee2f1678668fbb7a")
+ (revision "0"))
+ (package
+ (name "guile-avatar")
+ (version (git-version "0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/lechner/guile-avatar")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1dq9zcx4q3m5s3cpixq4zvlmdrlcc626mpqb7nmmj7vnda8k717f"))))
+ (build-system guile-build-system)
+ (arguments
+ (list #:source-directory "scm"))
+ (inputs (list guile-3.0))
+ (propagated-inputs (list guile-hashing))
+ (home-page "https://codeberg.org/lechner/guile-avatar")
+ (synopsis "Get Libravatar URLs from an email address")
+ (description
+ "@code{guile-avatar} helps you to determine avatars (or profile
+pictures) for email addresses using the Libravatar specification.")
+ (license license:agpl3+))))
+
(define-public guile2.0-bash
;; This project is currently retired. It was initially announced here:
;; <https://lists.gnu.org/archive/html/guile-user/2015-02/msg00003.html>.