summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:24:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:47 +0200
commitb29fd45b6a4bacbfe3c0509af30c665343610910 (patch)
treeb7180c0b9d2cb78015a690a9a8bded15f7a7105f
parent7490ea97d5b20957bc67da956b58a845b67195f4 (diff)
gnu: Add texlive-texcount.
* gnu/packages/tex.scm (texlive-texcount): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 36823c197c..9ee6b6c1aa 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6246,6 +6246,27 @@ the conversion engine.")
special characters to Unicode.")
(license license:expat)))
+(define-public texlive-texcount
+ (package
+ (name "texlive-texcount")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/support/texcount/" "scripts/texcount/")
+ (base32
+ "0ab1kp0zh2r65x1v42sc5bwxmlifa8splrakq589fgd0aap0l8n1")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "texcount.pl")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/texcount")
+ (synopsis "Count words in a LaTeX document")
+ (description
+ "TeXcount is a Perl script that counts words in the text of LaTeX files.
+It has rules for handling most of the common macros, and can provide
+colour-coded output showing which parts of the text have been counted.")
+ (license license:lppl)))
+
(define-public texlive-texdraw
(package
(name "texlive-texdraw")