summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-04-06 11:40:42 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 21:47:10 +0100
commitb315f4d5753374ebfc8e99f913bfd65fbacf3ba5 (patch)
tree103d3a6f7c7e6dbf821db033a67904d05f9d4d33
parentd4686ff6117c49d1181152820753f978fae5734d (diff)
gnu: Add go-github-com-multiformats-go-multibase.
* gnu/packages/golang-xyz.scm (go-github-com-multiformats-go-multibase): New variable. Change-Id: If634f1497d628a23f2c2ebb1e8e9f6526faa3f3f Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-xyz.scm43
1 files changed, 42 insertions, 1 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 9b3c387fd5..dfd4190a7d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -62,7 +62,8 @@
#:use-module (gnu packages golang-check)
#:use-module (gnu packages golang-compression)
#:use-module (gnu packages golang-crypto)
- #:use-module (gnu packages linux))
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages specifications))
;;; Commentary:
;;;
@@ -2170,6 +2171,46 @@ command line flags, config files, and default struct values.")
"Optimized codec for @code{[]byte} <=> @code{base36} string conversion.")
(license (list license:asl2.0 license:expat))))
+(define-public go-github-com-multiformats-go-multibase
+ (package
+ (name "go-github-com-multiformats-go-multibase")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/multiformats/go-multibase")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "11za5yqiq9bkxfg0lvjzgr5d0kawkf2szxj90by9vfnalihqgkrr"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "github.com/multiformats/go-multibase"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'copy-multibase-specs
+ (lambda* (#:key import-path #:allow-other-keys)
+ (copy-recursively
+ (string-append #$(this-package-native-input
+ "specification-multibase")
+ "/share/multibase/")
+ (string-append "src/" import-path "/spec")))))))
+ (native-inputs
+ (list specification-multibase))
+ (propagated-inputs
+ (list go-github-com-mr-tron-base58
+ go-github-com-multiformats-go-base32
+ go-github-com-multiformats-go-base36))
+ (home-page "https://github.com/multiformats/go-multibase")
+ (synopsis "Implementation of multibase parser in Go")
+ (description
+ "Implementation of @url{https://github.com/multiformats/multibase,
+multibase} (self identifying base encodings) in Go.")
+ (license license:expat)))
+
(define-public go-github-com-multiformats-go-varint
(package
(name "go-github-com-multiformats-go-varint")