summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-05-29 15:39:01 -0400
committerLeo Famulari <leo@famulari.name>2018-05-29 16:00:02 -0400
commitb50196c3a4275bc51a614f6c1945b2272c595ab8 (patch)
tree3cd9c89577b85c5f74c3c7e77722e6ca1327274b
parent0eeade9b5338774eb22fc79365a606fe45cb002a (diff)
gnu: Git: Update to 2.17.1 [fixes CVE 2018-{11234,11235}].
* gnu/packages/version-control.scm (git): Update to 2.17.1.
-rw-r--r--gnu/packages/version-control.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 603e8a46dd..7765936a3f 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -142,14 +142,14 @@ as well as the classic centralized workflow.")
(name "git")
;; XXX When updating Git, check if the special 'git:src' input to cgit needs
;; to be updated as well.
- (version "2.17.0")
+ (version "2.17.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "1ismz7nsz8dgjmk782xr9s0mr2qh06f72pdcgbxfmnw1bvlya5p9"))))
+ "0pm6bdnrrm165k3krnazxcxadifk2gqi30awlbcf9fism1x6w4vr"))))
(build-system gnu-build-system)
(native-inputs
`(("native-perl" ,perl)
@@ -162,7 +162,7 @@ as well as the classic centralized workflow.")
version ".tar.xz"))
(sha256
(base32
- "09rpjj0m97h5lpzpwk47m6xsz9gb8wqf1s3dfqma3mwav2pb3njb"))))))
+ "0m7grrwsqaihdgcgaicxiy4rlqjpa75n5wl6hi2qhi33xa34gmc3"))))))
(inputs
`(("curl" ,curl)
("expat" ,expat)