summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-18 20:29:30 +0100
committerMarius Bakke <marius@gnu.org>2022-11-19 22:07:33 +0100
commitb654726c4547364b035a7389ab25ee98c84b9308 (patch)
treedbc1cb3e741b0911435270a7a723f0027d82d600
parent5c9164d5fbd6396edfa433ca19a4da84a7ce45eb (diff)
gnu: vtk: Update to 9.2.2.
* gnu/packages/patches/vtk-fix-freetypetools-build-failure.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/image-processing.scm (vtk): Update to 9.2.2. [source](patches): Remove. [arguments]: Remove #:phases.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/image-processing.scm14
-rw-r--r--gnu/packages/patches/vtk-fix-freetypetools-build-failure.patch32
3 files changed, 2 insertions, 45 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index e51453aba9..4fc491a315 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1984,7 +1984,6 @@ dist_patch_DATA = \
%D%/packages/patches/vsearch-unbundle-cityhash.patch \
%D%/packages/patches/vte-CVE-2012-2738-pt1.patch \
%D%/packages/patches/vte-CVE-2012-2738-pt2.patch \
- %D%/packages/patches/vtk-fix-freetypetools-build-failure.patch \
%D%/packages/patches/vtk-7-gcc-10-compat.patch \
%D%/packages/patches/vtk-7-hdf5-compat.patch \
%D%/packages/patches/vtk-7-python-compat.patch \
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 2c2cea1fac..fb45e9b141 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -316,7 +316,7 @@ many popular formats.")
(define-public vtk
(package
(name "vtk")
- (version "9.0.1")
+ (version "9.2.2")
(source (origin
(method url-fetch)
(uri (string-append "https://vtk.org/files/release/"
@@ -324,9 +324,7 @@ many popular formats.")
"/VTK-" version ".tar.gz"))
(sha256
(base32
- "1ir2lq9i45ls374lcmjzw0nrm5l5hnm1w47lg8g8d0n2j7hsaf8v"))
- (patches
- (search-patches "vtk-fix-freetypetools-build-failure.patch"))
+ "0x8h2bwxq2870067j7wqd0qym87pa3inkbri93zrdb0zwwmhlnqw"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -375,14 +373,6 @@ many popular formats.")
"-DVTK_WRAP_PYTHON=ON"
"-DVTK_PYTHON_VERSION:STRING=3"
)
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-sources
- (lambda _
- (substitute* "Common/Core/vtkFloatingPointExceptions.cxx"
- (("<fenv.h>") "<cfenv>"))
- (substitute* "Common/Core/CMakeLists.txt"
- (("fenv.h") "cfenv")))))
#:tests? #f)) ;XXX: test data not included
(inputs
(list double-conversion
diff --git a/gnu/packages/patches/vtk-fix-freetypetools-build-failure.patch b/gnu/packages/patches/vtk-fix-freetypetools-build-failure.patch
deleted file mode 100644
index 23f651b5eb..0000000000
--- a/gnu/packages/patches/vtk-fix-freetypetools-build-failure.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-This fixes a build failure in VTK when building against recent versions
-of freetype.
-
- https://gitlab.kitware.com/vtk/vtk/-/merge_requests/7432
-
-Patch by Ben Boeckel <ben.boeckel@kitware.com>
-
-Subject: [PATCH] vtkFreeTypeTools: avoid using an internal macro
-
-This macro has been removed upstream as it was always intended to be
-private.
----
- Rendering/FreeType/vtkFreeTypeTools.cxx | 7 ++-----
- 1 file changed, 2 insertions(+), 5 deletions(-)
-
-diff --git a/Rendering/FreeType/vtkFreeTypeTools.cxx b/Rendering/FreeType/vtkFreeTypeTools.cxx
-index c54289dc60..03b899c4da 100644
---- a/Rendering/FreeType/vtkFreeTypeTools.cxx
-+++ b/Rendering/FreeType/vtkFreeTypeTools.cxx
-@@ -378,8 +378,7 @@ FTC_CMapCache* vtkFreeTypeTools::GetCMapCache()
- }
-
- //----------------------------------------------------------------------------
--FT_CALLBACK_DEF(FT_Error)
--vtkFreeTypeToolsFaceRequester(
-+static FT_Error vtkFreeTypeToolsFaceRequester(
- FTC_FaceID face_id, FT_Library lib, FT_Pointer request_data, FT_Face* face)
- {
- #if VTK_FTFC_DEBUG_CD
---
-2.30.1
-