summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrett Gilio <brettg@posteo.net>2019-12-09 15:34:01 -0600
committerBrett Gilio <brettg@posteo.net>2019-12-09 15:34:01 -0600
commitb657b23ffb05a8eb22f91fe05bdfcd140081d93a (patch)
tree02b88b9fda86175854b9b37c3289cfc04a201743
parent24ba2cee2b1671c5dae36bb4cdba139f1fd09023 (diff)
gnu: Add python-ujson.
* gnu/packages/python-xyz.scm (python-ujson): New variable.
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e002b972e9..244eb1842f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16749,3 +16749,26 @@ services such as upower, systemd, logind, gnome-session or others, and it is
hard (or impossible without root privileges) to set the state of the real
services to what you expect in your tests.")
(license license:lgpl3+)))
+
+(define-public python-ujson
+ (package
+ (name "python-ujson")
+ (version "1.35")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ujson" version))
+ (sha256
+ (base32
+ "11jz5wi7mbgqcsz52iqhpyykiaasila4lq8cmc2d54bfa3jp6q7n"))))
+ (build-system python-build-system)
+ (home-page "http://www.esn.me")
+ (synopsis
+ "Ultra fast JSON encoder and decoder for Python")
+ (description
+ "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with
+ bindings for Python 2.5+ and 3.")
+ (license license:bsd-3)))
+
+(define-public python2-ujson
+ (package-with-python2 python-ujson))