summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-06-25 22:28:15 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:00 +0200
commitb67d61a05b15d2eae32eb5f84c82291c4ae7e57e (patch)
treecb883a0b0656eb93aa19c4fe7cd59bfece3b886f
parente5f6d0ecafba223031d8f379a91961842ca593a6 (diff)
gnu: eye: Fetch sources from Git.
* gnu/packages/astronomy.scm (eye)[source]: Use GIT-FETCH and GIT-FILE-NAME. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/astronomy.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index b2567b992a..564dbbe71b 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -645,11 +645,13 @@ International Astronomical Union}.")
(version "1.4.1")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://www.astromatic.net/download/eye/"
- "eye-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/astromatic/eye")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "092qhzcbrkcfidbx4bv9wz42w297n80jk7a6kwyi9a3fjfz81d7k"))))
+ (base32 "1j8rpgz3fjp6fw0qmxgfqycf3n01fzxds4w12vgyrhbnk658ia41"))))
(build-system gnu-build-system)
(arguments
(list