summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Becze <mjbecze@riseup.net>2021-04-14 05:20:08 -0500
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 14:21:00 +0000
commitb68544731d8fafe317ed54b3197b1cc6ff72f3a5 (patch)
tree7cf050ffd805d93e59e8c91be1e60b3fd0a7ac8d
parent699c9a04b258cfb512ef13c20560fc277f94f7d5 (diff)
gnu: Add go-github-com-marcinbor85-gohex.
* gnu/packages/golang-xyz.scm (go-github-com-marcinbor85-gohex): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I39e8cd725819d549d562f5168e1651c22bfa50b6
-rw-r--r--gnu/packages/golang-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 4eb92365f6..c594629d83 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1486,6 +1486,41 @@ word-splitting rules.")
(home-page "https://github.com/kballard/go-shellquote")
(license license:expat))))
+(define-public go-github-com-marcinbor85-gohex
+ ;; No release, see <https://github.com/marcinbor85/gohex/issues/5>.
+ (let ((commit "baab2527a9a2a4abb3dc06baabedfa5e0268b8d8")
+ (revision "0"))
+ (package
+ (name "go-github-com-marcinbor85-gohex")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/marcinbor85/gohex")
+ (commit commit)))
+ (sha256
+ (base32 "06v4cc6ld6vvxd4xm9k6l49lhcd9ncq7xfx35mj5b9r96ih49fiz"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/marcinbor85/gohex"))
+ (home-page "https://pkg.go.dev/github.com/marcinbor85/gohex")
+ (synopsis "Parse Intel HEX files")
+ (description
+ "This package provides a Golang library for parsing Intel HEX files,
+implementing features like:
+
+@itemize
+@item robust intelhex parsing (full test coverage)
+@item support i32hex format
+@item two-way converting hex<->bin
+@item trivial but powerful api (only the most commonly used functions)
+@item interface-based IO functions
+@end itemize")
+ (license license:expat))))
+
(define-public go-github-com-matryer-try
(package
(name "go-github-com-matryer-try")