summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-03 08:24:53 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:45 -0500
commitb69d4aa7f82673917f47268cfbcad5fbae460170 (patch)
tree2383e6813a3746cfb1cc11eec559e956033d62c5
parente71fb57349109ec42207afe139153e578c43cd99 (diff)
gnu: Add ghc-unicode-transforms.
* gnu/packages/haskell-xyz.scm (ghc-unicode-transforms): New variable.
-rw-r--r--gnu/packages/haskell-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index ba6bd3ea19..3c75e38f40 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -11214,6 +11214,32 @@ unbounded @code{Integer} type.")
handled safely, this is what you're left with.")
(license license:isc)))
+(define-public ghc-unicode-transforms
+ (package
+ (name "ghc-unicode-transforms")
+ (version "0.3.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "unicode-transforms/unicode-transforms-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1akscvyssif4hki3g6hy0jmjyr8cqly1whzvzj0km2b3qh0x09l3"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-bitarray" ,ghc-bitarray)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-getopt-generics" ,ghc-getopt-generics)
+ ("ghc-split" ,ghc-split)))
+ (home-page "https://github.com/composewell/unicode-transforms")
+ (synopsis "Unicode normalization")
+ (description "This library provides tools for fast Unicode 12.1.0
+normalization in Haskell (normalization forms C, KC, D, and KD).")
+ (license license:bsd-3)))
+
(define-public ghc-union-find
(package
(name "ghc-union-find")