summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-10-08 13:38:22 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-10-08 13:38:22 +0200
commitb8d4524b6c0ee19aed08fbcf7157fa325ec48764 (patch)
treebcfaee755348120a11566e9a7ee8cf36b8ee0e9d
parent6e29cd1f452922a3c625315fe83fb3803b737f54 (diff)
gnu: ocaml-parsexp: Update to 0.14.1.
* gnu/packages/ocaml.scm (ocaml-parsexp): Update to 0.14.1.
-rw-r--r--gnu/packages/ocaml.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 534d065016..d350b7f992 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4799,11 +4799,17 @@ that was developed by Jane Street, the largest industrial user of OCaml.")
(define-public ocaml-parsexp
(package
(name "ocaml-parsexp")
- (version "0.14.0")
+ (version "0.14.1")
(home-page "https://github.com/janestreet/parsexp")
- (source
- (janestreet-origin "parsexp" version
- "158znj19dvfdcwsgzs3rdhxpj1g4aw0d4nkfr8c05bahf0lnshlb"))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1nr0ncb8l2mkk8pqzknr7fsqw5kpz8y102kyv5bc0x7c36v0d4zy"))))
(build-system dune-build-system)
(inputs
`(("ocaml-sexplib0" ,ocaml-sexplib0)