summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2019-09-27 22:19:39 -0500
committerEric Bavier <bavier@member.fsf.org>2019-09-27 22:23:44 -0500
commitba567cae9725f8adf717106f5b54baeb6efd89e4 (patch)
tree1454925fb036ee9c37bab1cdd9df0fdb718882ad
parent3e27f472dbe0037a8cdfa3423c1806be66a79e43 (diff)
gnu: dealii: Update to 9.1.1.
* gnu/packages/maths.scm (dealii): Update to 9.1.1. [source]: Remove patch no longer needed. * gnu/local.mk (dist_patch_DATA): ditto. * gnu/packages/patches/dealii-mpi-deprecations.patch: Delete it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/maths.scm5
-rw-r--r--gnu/packages/patches/dealii-mpi-deprecations.patch28
3 files changed, 2 insertions, 32 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a6fe439904..b04a5d796e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -764,7 +764,6 @@ dist_patch_DATA = \
%D%/packages/patches/darkice-workaround-fpermissive-error.patch \
%D%/packages/patches/dbus-helper-search-path.patch \
%D%/packages/patches/dbus-CVE-2019-12749.patch \
- %D%/packages/patches/dealii-mpi-deprecations.patch \
%D%/packages/patches/debops-constants-for-external-program-names.patch \
%D%/packages/patches/debops-debops-defaults-fall-back-to-less.patch \
%D%/packages/patches/deja-dup-use-ref-keyword-for-iter.patch \
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 2e0883a724..291a367a2f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3636,7 +3636,7 @@ revised simplex and the branch-and-bound methods.")
(define-public dealii
(package
(name "dealii")
- (version "9.0.1")
+ (version "9.1.1")
(source
(origin
(method url-fetch)
@@ -3644,8 +3644,7 @@ revised simplex and the branch-and-bound methods.")
"download/v" version "/dealii-" version ".tar.gz"))
(sha256
(base32
- "0r7f8rhl3xr94imd372plizdcbqk0a70w73lwc3vw912dxk0sbyz"))
- (patches (search-patches "dealii-mpi-deprecations.patch"))
+ "0xhjv0gzswpjbc43xbrpwfc5848g508l01855nszx3g5gwzlhnzw"))
(modules '((guix build utils)))
(snippet
;; Remove bundled sources: UMFPACK, TBB, muParser, and boost
diff --git a/gnu/packages/patches/dealii-mpi-deprecations.patch b/gnu/packages/patches/dealii-mpi-deprecations.patch
deleted file mode 100644
index 816d54140a..0000000000
--- a/gnu/packages/patches/dealii-mpi-deprecations.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 40538ad31a71495649d174b0f7be5f7135d0a905 Mon Sep 17 00:00:00 2001
-From: David Wells <drwells@email.unc.edu>
-Date: Sat, 2 Feb 2019 10:00:38 -0500
-Subject: [PATCH] Avoid calling a deprecated MPI function.
-
-This was deprecated a long time ago (1996) and is not present in the
-latest version of openMPI (4.0): see
-
-https://www.open-mpi.org/faq/?category=mpi-removed
-
-Credit goes to Pratik Nayak for finding this issue.
----
- source/base/mpi.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/source/base/mpi.cc b/source/base/mpi.cc
-index bd1f7f9846a..b8cd45e7c26 100644
---- a/source/base/mpi.cc
-+++ b/source/base/mpi.cc
-@@ -448,7 +448,7 @@ namespace Utilities
- MPI_Aint displacements[] = {0, offsetof(MinMaxAvg, min_index)};
- MPI_Datatype types[] = {MPI_DOUBLE, MPI_INT};
-
-- ierr = MPI_Type_struct(2, lengths, displacements, types, &type);
-+ ierr = MPI_Type_create_struct(2, lengths, displacements, types, &type);
- AssertThrowMPI(ierr);
-
- ierr = MPI_Type_commit(&type);