summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-18 19:59:59 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-04-18 20:02:24 +0300
commitbb721d88618d93d38aa5dfc33629e223c8b1c884 (patch)
tree9addf6e80791c72c4a1a827735dd5c4027370bcc
parent4d030fbd484cba03d6bea2e92351ea30518fe50d (diff)
gnu: gnutls: Extend test timeout on powerpc-linux.
* gnu/packages/tls.scm (gnutls)[arguments]: When building for powerpc-linux add a phase to extend the test timeout.
-rw-r--r--gnu/packages/tls.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 5a44fa89dc..9a1de0fdd8 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016, 2017, 2019, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2019, 2021-2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017, 2018 Nikita <nikita@n0.is>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
@@ -284,6 +284,13 @@ living in the same process.")
(substitute* "tests/fastopen.sh"
(("^unset RETCODE")
"exit 77\n")))) ;skip
+ ,@(if (target-ppc32?)
+ ;; https://gitlab.com/gnutls/gnutls/-/issues/1354
+ ;; Extend the test timeout from the default of 20 * 1000
+ `((add-after 'unpack 'increase-test-timeout
+ (lambda _
+ (setenv "GNUTLS_TEST_TIMEOUT" "60000"))))
+ '())
(add-after 'install 'move-doc
(lambda* (#:key outputs #:allow-other-keys)
;; Copy the 4.1 MiB of section 3 man pages to "doc".