summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-03 19:57:15 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-05 16:39:37 +0100
commitbdd4aa16433a57e4d7bb8980f9e8619d43785b0e (patch)
tree6aa4abafa0da140a6ba2b98b5e52642668adbb14
parentf1c2aed7df194d37b6f201ae9beb7e71a6847dd2 (diff)
gnu: ghc-comonad: Run tests.
* gnu/packages/haskell.scm (ghc-comonad)[arguments]: Delete to enable tests. [native-inputs]: Add ghc-doctest.
-rw-r--r--gnu/packages/haskell.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index cd0edbe229..66ccbae7f4 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2362,8 +2362,8 @@ parser isolation, and labeled blocks for better error messages.")
(base32
"0arvbaxgkawzdp38hh53akkahjg2aa3kj2b4ns0ni8a5ylg2cqmp"))))
(build-system haskell-build-system)
- (arguments `(#:tests? #f)) ; FIXME: Test fails with "cannot satisfy
- ; -package contravariant-1.3.3"
+ (native-inputs
+ `(("ghc-doctest" ,ghc-doctest)))
(inputs
`(("ghc-contravariant" ,ghc-contravariant)
("ghc-distributive" ,ghc-distributive)