summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-03 11:14:29 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-04 00:46:03 -0500
commitbe73447995d6a14ef6b6c3e1011e7a3020d72d96 (patch)
tree3efbf3b093506bea5453bab0403b1a8f888de166
parent57c2680e5c8aabf92703b40c4efaf5a485ebd092 (diff)
gnu: Add Catalyst-Plugin-Session-State-Cookie.
* gnu/packages/web.scm (perl-catalyst-plugin-session-state-cookie): New variable.
-rw-r--r--gnu/packages/web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b32cf2aaf6..3ad74e13f6 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -866,6 +866,35 @@ formats.")
management in web applications together: the state, and the store.")
(license (package-license perl))))
+(define-public perl-catalyst-plugin-session-state-cookie
+ (package
+ (name "perl-catalyst-plugin-session-state-cookie")
+ (version "0.17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/M/MS/MSTROUT/"
+ "Catalyst-Plugin-Session-State-Cookie-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1rvxbfnpf9x2pc2zgpazlcgdlr2dijmxgmcs0m5nazs0w6xikssb"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-catalyst-plugin-session" ,perl-catalyst-plugin-session)
+ ("perl-catalyst-runtime" ,perl-catalyst-runtime)
+ ("perl-moose" ,perl-moose)
+ ("perl-mro-compat" ,perl-mro-compat)
+ ("perl-namespace-autoclean" ,perl-namespace-autoclean)))
+ (home-page
+ "http://search.cpan.org/dist/Catalyst-Plugin-Session-State-Cookie")
+ (synopsis "Maintain session IDs using cookies")
+ (description "In order for Catalyst::Plugin::Session to work, the session
+ID needs to be stored on the client, and the session data needs to be stored
+on the server. This plugin stores the session ID on the client using the
+cookie mechanism.")
+ (license (package-license perl))))
+
(define-public perl-catalyst-plugin-static-simple
(package
(name "perl-catalyst-plugin-static-simple")