summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-28 18:41:04 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-28 18:41:04 +0100
commitbf1f2122698e37aa796d5446ed9d027b0245730a (patch)
treea5a3e9ab8c908fe9a78913ad7ab2e2b210fb1cca
parentb0e9736103ec47ff644a8fc6245ffc5cc25e48d9 (diff)
gnu: Add emacs-hsluv.
* gnu/packages/emacs-xyz.scm (emacs-hsluv): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d58495db87..50f3929aa4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -693,6 +693,33 @@ editing @file{.hgignore} files used by the Mercurial version control
system.")
(license license:gpl3+))))
+(define-public emacs-hsluv
+ (package
+ (name "emacs-hsluv")
+ (version "20181127.1206")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hsluv/hsluv-emacs.git")
+ (commit "c3bc5228e30d66e7dee9ff1a0694c2b976862fc0")))
+ (sha256
+ (base32
+ "19q8qlq4s2kfydpadkq1zd92611dvq7dr8vlhlbd9gplzpx7dhfd"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-seq))
+ (home-page "https://github.com/hsluv/hsluv-emacs")
+ (synopsis "HSLuv color space conversions")
+ (description
+ "This package provides an elisp implementation of the HSLUV colorspace
+conversions documented on @url{http://www.hsluv.org/}. HSLuv is a
+human-friendly alternative to HSL. CIELUV is a color space designed for
+perceptual uniformity based on human experiments. When accessed by polar
+coordinates, it becomes functionally similar to HSL with a single problem: its
+chroma component doesn't fit into a specific range. HSLuv extends CIELUV with
+a new saturation component that allows you to span all the available chroma as
+a neat percentage.")
+ (license license:expat)))
+
(define-public emacs-platformio-mode
(package
(name "emacs-platformio-mode")