summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-09 21:27:15 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:00:11 +0200
commitc178ffcaf2a203642c9c29f8f995cfc8c69857f7 (patch)
tree91f1bbfc76571e4b6abf3cb2c6cc47e4be366c35
parentb1679379001e2f35f13e35bf3b2a4c40910abd25 (diff)
gnu: Add texlive-latex-ucs.
* gnu/packages/tex.scm (texlive-latex-ucs): New variable.
-rw-r--r--gnu/packages/tex.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3b9fb275fc..331fb3453b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2483,6 +2483,46 @@ lasy font set and other odds and ends. The wasysym package implements an easy
to use interface for these symbols.")
(license license:lppl)))
+(define-public texlive-latex-ucs
+ (package
+ (name "texlive-latex-ucs")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/latex/ucs"))
+ (revision %texlive-revision)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0rrxwi60wmz5dfjifl4fwk66plf7wix85qnhfv4ylvmj6qi6hw37"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/latex/ucs")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "http://www.ctan.org/pkg/ucs")
+ (synopsis "Extended UTF-8 input encoding support for LaTeX")
+ (description
+ "The bundle provides the @code{ucs} package, and @code{utf8x.def},
+together with a large number of support files. The @code{utf8x.def}
+definition file for use with @code{inputenc} covers a wider range of Unicode
+characters than does @code{utf8.def} in the LaTeX distribution. The package
+provides facilities for efficient use of its large sets of Unicode characters.
+Glyph production may be controlled by various options, which permits use of
+non-ASCII characters when coding mathematical formulae. Note that the bundle
+previously had an alias “unicode”; that alias has now been withdrawn, and no
+package of that name now exists.")
+ (license license:lppl1.3+)))
+
(define texlive-texmf
(package
(name "texlive-texmf")