summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-26 07:28:25 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 10:54:37 +0000
commitc1be2c6b8b667697b23b2405637a24bb8888e72a (patch)
treee929aad6dd4fbd9aebe9a9b4107094814bbcf9f9
parenta1ab329f33c666aa1eaa7444320b641487b8419c (diff)
gnu: gvfs: Update to 1.48.1.
* gnu/packages/patches/gvfs-add-support-for-libplist-2.2.patch: Remove it. * gnu/local.mk (DIST_PATCH_DATA): Update it. * gnu/packages/gnome.scm (gvfs)[source]: Remove the patch. [inputs]: Switch to fuse@3 and add gsettings-desktop-schemas. [properties]: Remove it. [description]: Wrap it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm20
-rw-r--r--gnu/packages/patches/gvfs-add-support-for-libplist-2.2.patch34
3 files changed, 7 insertions, 48 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 23893034d5..15addbe72b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1218,7 +1218,6 @@ dist_patch_DATA = \
%D%/packages/patches/gtk4-respect-GUIX_GTK4_PATH.patch \
%D%/packages/patches/gtkglext-disable-disable-deprecated.patch \
%D%/packages/patches/gtksourceview-2-add-default-directory.patch \
- %D%/packages/patches/gvfs-add-support-for-libplist-2.2.patch \
%D%/packages/patches/gzdoom-search-in-installed-share.patch \
%D%/packages/patches/gzdoom-find-system-libgme.patch \
%D%/packages/patches/hdf4-architectures.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2d643343cb..e9b132adb8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6493,7 +6493,7 @@ part of udev-extras, then udev, then systemd. It's now a project on its own.")
(define-public gvfs
(package
(name "gvfs")
- (version "1.40.2")
+ (version "1.48.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/gvfs/"
@@ -6501,10 +6501,7 @@ part of udev-extras, then udev, then systemd. It's now a project on its own.")
"gvfs-" version ".tar.xz"))
(sha256
(base32
- "07lpcfric3h0302n9b1pwa38mjb76r9s98kg2867y2d1qvzfivxx"))
- ;; This patch may be removed when upgrading to version 1.46.x.
- (patches
- (search-patches "gvfs-add-support-for-libplist-2.2.patch"))))
+ "1hlxl6368h6nyqp1888szxs9hnpcw98k3h23dgqi29xd38klzsmj"))))
(build-system meson-build-system)
(arguments
'(#:glib-or-gtk? #t
@@ -6526,10 +6523,11 @@ part of udev-extras, then udev, then systemd. It's now a project on its own.")
("docbook-xsl" ,docbook-xsl)
("dbus" ,dbus)
("elogind" ,elogind)
- ("fuse" ,fuse)
+ ("fuse" ,fuse-3)
("gcr" ,gcr)
("glib" ,glib)
("gnome-online-accounts" ,gnome-online-accounts)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("libarchive" ,libarchive)
("libbluray" ,libbluray)
("libcap" ,libcap)
@@ -6548,17 +6546,13 @@ part of udev-extras, then udev, then systemd. It's now a project on its own.")
("openssh" ,openssh)
("polkit" ,polkit)
("udisks" ,udisks)))
- ;; CVE-2019-{12447,12448,12449} are fixed in the 1.40.2 release.
- (properties '((lint-hidden-cve . ("CVE-2019-12447"
- "CVE-2019-12448"
- "CVE-2019-12449"))))
(home-page "https://wiki.gnome.org/gvfs/")
(synopsis "Userspace virtual file system for GIO")
(description
"GVFS is a userspace virtual file system designed to work with the I/O
-abstraction of GIO. It contains a GIO module that seamlessly adds GVFS support
-to all applications using the GIO API. It also supports exposing the GVFS
-mounts to non-GIO applications using FUSE.
+abstraction of GIO. It contains a GIO module that seamlessly adds GVFS
+support to all applications using the GIO API. It also supports exposing the
+GVFS mounts to non-GIO applications using FUSE.
GVFS comes with a set of backends, including trash support, SFTP, SMB, HTTP,
DAV, and others.")
diff --git a/gnu/packages/patches/gvfs-add-support-for-libplist-2.2.patch b/gnu/packages/patches/gvfs-add-support-for-libplist-2.2.patch
deleted file mode 100644
index 250eef2c8b..0000000000
--- a/gnu/packages/patches/gvfs-add-support-for-libplist-2.2.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Source: https://gitlab.gnome.org/GNOME/gvfs/-/commit/13551f3f40d41f1357126ac5a26d0fa012cd8123
-
-Note: This change should be incorporated into stable version 1.46.x of gvfs.
-
-From 13551f3f40d41f1357126ac5a26d0fa012cd8123 Mon Sep 17 00:00:00 2001
-From: Bastien Nocera <hadess@hadess.net>
-Date: Tue, 16 Jun 2020 13:28:35 +0200
-Subject: [PATCH] afc: Add support for libplist-2.2
-
-Which changed name from libplist to libplist-2.0 to embed its API
-version number in the library name.
----
- meson.build | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/meson.build b/meson.build
-index 1750f65ca..187bfd55f 100644
---- a/meson.build
-+++ b/meson.build
-@@ -357,7 +357,10 @@ config_h.set('HAVE_LOGIND', enable_logind)
- enable_afc = get_option('afc')
- if enable_afc
- libimobiledevice_dep = dependency('libimobiledevice-1.0', version: '>= 1.2')
-- libplist_dep = dependency('libplist', version: '>= 0.15')
-+ libplist_dep = dependency('libplist-2.0', required: false)
-+ if not libplist_dep.found()
-+ libplist_dep = dependency('libplist', version: '>= 0.15')
-+ endif
- endif
-
- # *** Check if we should build with GOA volume monitor ***
---
-GitLab
-