summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-10 14:22:13 -0400
committerMark H Weaver <mhw@netris.org>2015-07-10 23:47:07 -0400
commitc2ba49ef8ee1bb72513ecda8f22e29680ab208ef (patch)
treea746d9d67cb59072b0bed72657e282db9c293f6d
parent6f317fa365ebbf5c1f8e42826803db6bd423ba42 (diff)
gnu: coreutils: Update to 8.24.
* gnu/packages/patches/coreutils-dummy-man.patch: Remove file. * gnu-system.am (dist_patch_DATA): Remove it. * gnu/packages/base.scm (coreutils): Update to 8.24. Remove patch.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/base.scm5
-rw-r--r--gnu/packages/patches/coreutils-dummy-man.patch21
3 files changed, 2 insertions, 25 deletions
diff --git a/gnu-system.am b/gnu-system.am
index d6369b5ddd..bf9459d663 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -398,7 +398,6 @@ dist_patch_DATA = \
gnu/packages/patches/clang-libc-search-path.patch \
gnu/packages/patches/clucene-pkgconfig.patch \
gnu/packages/patches/cmake-fix-tests.patch \
- gnu/packages/patches/coreutils-dummy-man.patch \
gnu/packages/patches/cpio-CVE-2014-9112-pt1.patch \
gnu/packages/patches/cpio-CVE-2014-9112-pt2.patch \
gnu/packages/patches/cpio-CVE-2014-9112-pt3.patch \
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 31331a1080..9a433ae5e4 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -238,15 +238,14 @@ used to apply commands with arbitrarily long arguments.")
(define-public coreutils
(package
(name "coreutils")
- (version "8.23")
+ (version "8.24")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/coreutils/coreutils-"
version ".tar.xz"))
(sha256
(base32
- "0bdq6yggyl7nkc2pbl6pxhhyx15nyqhz3ds6rfn448n6rxdwlhzc"))
- (patches (list (search-patch "coreutils-dummy-man.patch")))))
+ "0w11jw3fb5sslf0f72kxy7llxgk1ia3a6bcw0c9kmvxrlj355mx2"))))
(build-system gnu-build-system)
(inputs `(("acl" ,acl) ; TODO: add SELinux
("gmp" ,gmp)))
diff --git a/gnu/packages/patches/coreutils-dummy-man.patch b/gnu/packages/patches/coreutils-dummy-man.patch
deleted file mode 100644
index a43cfc47c3..0000000000
--- a/gnu/packages/patches/coreutils-dummy-man.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Patch adapted from <http://git.yoctoproject.org/cgit.cgi/poky/plain/meta/recipes-core/coreutils/coreutils-8.22/fix-for-dummy-man-usage.patch>.
-
-Fix for 'dummy-man' usage, when cross-compiling.
-
-The options should be before the final argument, otherwise, the following error
-would appear when compiling:
-
- dummy-man: too many non-option arguments
-
---- coreutils-8.23/Makefile.in 2014-07-18 18:22:24.000000000 -0400
-+++ coreutils-8.23/Makefile.in 2014-08-03 20:21:10.849158313 -0400
-@@ -14076,8 +14076,8 @@
- && $(run_help2man) \
- --source='$(PACKAGE_STRING)' \
- --include=$(srcdir)/man/$$name.x \
-- --output=$$t/$$name.1 $$t/$$argv \
- --info-page='coreutils \(aq'$$name' invocation\(aq' \
-+ --output=$$t/$$name.1 $$t/$$argv \
- && sed \
- -e 's|$*\.td/||g' \
- -e '/For complete documentation/d' \