summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-03-27 17:45:31 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-03-27 17:50:57 +0100
commitc2c1098585b10f42bed7647f2130a2727c0488f8 (patch)
tree4200365c297e12619b6fc4491ee6ce56340b9be2
parentca9d4d9448719928c30aa3e6d9e15e67b2662b9c (diff)
gnu: Add r-ggmosaic.
* gnu/packages/cran.scm (r-ggmosaic): New variable. Change-Id: Ia399265c01a57074b0cfc29dde45e1900ccc26de
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b8a7d3e944..4765d09dee 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6174,6 +6174,36 @@ Google Maps and Stamen Maps). It includes tools common to those tasks,
including functions for geolocation and routing.")
(license license:gpl2)))
+(define-public r-ggmosaic
+ (package
+ (name "r-ggmosaic")
+ (version "0.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ggmosaic" version))
+ (sha256
+ (base32 "1zm1zfbd0qk6icw65m9hz1hgyqj632ibq3qilidvx5jy7jh8nbpy"))))
+ (properties `((upstream-name . "ggmosaic")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-dplyr
+ r-ggplot2
+ r-ggrepel
+ r-plotly
+ r-productplots
+ r-purrr
+ r-rlang
+ r-scales
+ r-tidyr))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/haleyjeppson/ggmosaic")
+ (synopsis "Mosaic plots in the ggplot2 framework")
+ (description
+ "This package provides mosaic plots for the ggplot2 framework. Mosaic
+plot functionality is provided in a single ggplot2 layer by calling the
+@code{geom} @code{mosaic}.")
+ (license license:gpl2+)))
+
(define-public r-haven
(package
(name "r-haven")