summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:25:29 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:48 +0200
commitc3a49731f637d46c891c5b0b17056197438097dd (patch)
tree6477e3545e7f10f15f1e218710c2fa878ffca78d
parente2b7940ca683c75b19aa262ecb88846b93303fe2 (diff)
gnu: Add texlive-texdirflatten.
* gnu/packages/tex.scm (texlive-texdirflatten): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 28381e3ce8..a824a0b702 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6331,6 +6331,30 @@ with red with a strike-through line. Furthermore, passages with changes are
marked at the margin with grey bars by the LaTeX @code{changebar} package.")
(license license:artistic2.0)))
+(define-public texlive-texdirflatten
+ (package
+ (name "texlive-texdirflatten")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/texdirflatten.1"
+ "doc/man/man1/texdirflatten.man1.pdf"
+ "doc/support/texdirflatten/"
+ "scripts/texdirflatten/")
+ (base32
+ "0f2h9qlqfml9p83znxh81i7cmwfbsr0zrladrf3486v4aja859kx")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "texdirflatten")))
+ (home-page "https://ctan.org/pkg/texdirflatten")
+ (synopsis "Collect files related to a LaTeX job in a single directory")
+ (description
+ "The Perl script parses a LaTeX file recursively, scanning all child
+files, and collects details of any included and other data files. These
+component files, are then all put into a single directory (thus flattening the
+document's directory tree).")
+ (license license:artistic2.0)))
+
(define-public texlive-texdraw
(package
(name "texlive-texdraw")