summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:59:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:38 +0200
commitc4a4d71f577d0514f5eee8e8b649d0823203a4e2 (patch)
treedc4e34f83c3b71e9add61cd6193645992a0d8336
parent92f40b4e5badc18950fad4f4f66fe4f4b0e35aed (diff)
gnu: Add texlive-path.
* gnu/packages/tex.scm (texlive-path): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f3325e24c9..26bcf35111 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3294,6 +3294,26 @@ prevents TeX from optimising away maths penalties and the like, that are
needed when the material is @code{\\unhbox}'ed.")
(license license:gpl3+)))
+(define-public texlive-path
+ (package
+ (name "texlive-path")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/path/" "tex/generic/path/")
+ (base32
+ "09m1f9si97hrfqsyj0mzbi9djgk0w4vq13yd3v0af9v3240h1ps2")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/path")
+ (synopsis "Typeset paths, making them breakable")
+ (description
+ "This package defines a macro @code{\\path|...|}, similar to the LaTeX
+@code{\\verb|...|}, that sets the text in typewriter font and allows
+hyphen-less breaks at punctuation characters. The set of characters to be
+regarded as punctuation may be changed from the package's default.")
+ (license license:knuth)))
+
(define-public texlive-tex
(package
(name "texlive-tex")