summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-01-30 16:25:15 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:51 +0200
commitc627f2f74308dec3e42b5cb62e1c0fee98c54ccc (patch)
treec4579184cac2ae2eff914fa8230b28aff7e412f0
parent874a8c4f5b2d842143e1097f21e4425a15b19017 (diff)
gnu: Add rust-ordered-stream-0.2.
* gnu/packages/crates-io.scm (rust-ordered-stream-0.2): Add variable. (rust-ordered-stream-0.1): Inherit from rust-ordered-stream-0.2. Change-Id: I24169187e93fe2b08fe85a9d3ba6290b9f751dc3 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm31
1 files changed, 22 insertions, 9 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d65f5104ae..0e87545d07 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -43407,17 +43407,17 @@ PartialOrd types, like floats.")
insertion order across all keys and values.")
(license license:expat)))
-(define-public rust-ordered-stream-0.1
+(define-public rust-ordered-stream-0.2
(package
(name "rust-ordered-stream")
- (version "0.1.4")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "ordered-stream" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "140c0h0ap30mcfhdk2xy1q9iqyb450wh11dglshh2y6vmjyj82in"))))
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ordered-stream" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0l0xxp697q7wiix1gnfn66xsss7fdhfivl2k7bvpjs4i3lgb18ls"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -43432,6 +43432,19 @@ insertion order across all keys and values.")
external events in Rust.")
(license (list license:expat license:asl2.0))))
+(define-public rust-ordered-stream-0.1
+ (package
+ (inherit rust-ordered-stream-0.2)
+ (name "rust-ordered-stream")
+ (version "0.1.4")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "ordered-stream" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "140c0h0ap30mcfhdk2xy1q9iqyb450wh11dglshh2y6vmjyj82in"))))))
+
(define-public rust-ordermap-0.3
(package
(name "rust-ordermap")