summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-11 02:39:31 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-31 13:15:24 -0400
commitc82c6807e87736f839faebc51604f8abd7268228 (patch)
treef224a8364bc8d24f58fead57c6a0447170cc9fce
parent5e7f27d6ca7be84453e6d4de3d860b700ba3aef7 (diff)
gnu: Add python-radio-beam.
* gnu/packages/astronomy.scm (python-radio-beam): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/astronomy.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 764a674a6d..74e9cb753b 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3955,6 +3955,40 @@ format, which are used by ASDF to serialize and deserialize data for the Nancy
Grace Roman Space Telescope.")
(license license:bsd-3)))
+(define-public python-radio-beam
+ (package
+ (name "python-radio-beam")
+ (version "0.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "radio-beam" version))
+ (sha256
+ (base32 "0293hlbxb61h8js7yrvrbiw8108qn5s0rh2iy9rkhc012mzjacp0"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-astropy
+ python-matplotlib
+ python-numpy
+ python-scipy
+ python-six))
+ (native-inputs (list python-pytest-astropy))
+ (home-page "https://radio-beam.readthedocs.io/en/latest/")
+ (synopsis "Operations for radio astronomy beams with Astropy")
+ (description
+ "Radio Beam is a simple toolkit for reading beam information from FITS
+headers and manipulating beams.
+Some example applications include:
+@itemize
+@item Convolution and deconvolution
+@item Unit conversion (Jy to/from K)
+@item Handle sets of beams for spectral cubes with varying resolution between
+channels
+@item Find the smallest common beam from a set of beams
+@item Add the beam shape to a matplotlib plot
+@end itemize")
+ (license license:bsd-3)))
+
(define-public python-roman-datamodels
(package
(name "python-roman-datamodels")