summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWiktor Żelazny <wzelazny@vurv.cz>2022-09-01 13:38:06 +0200
committerLudovic Courtès <ludo@gnu.org>2022-09-08 16:22:22 +0200
commitc92b01080494cf5641a33c805d0b2f80c64c6a88 (patch)
treeddf26e6c6ecbb6e47e9e0cabaa468bcfe9d053ab
parent7627ac7ba950c272262bcbf0bb7757b583ff02f0 (diff)
gnu: Add texlive-latex-tabto-ltx.
* gnu/packages/tex.scm (texlive-latex-tabto-ltx): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/tex.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2236f9faf2..281f2904da 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11609,3 +11609,41 @@ through the introduction of a new label which can be referenced like
@code{\\pageref{LastPage}} to give a reference to the last page of a document.
It is particularly useful in the page footer that says: Page N of M.")
(license license:lppl1.3c+)))
+
+(define-public texlive-latex-tabto-ltx
+ (package
+ (name "texlive-latex-tabto-ltx")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference (url (string-append
+ "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/latex/tabto-ltx"))
+ (revision %texlive-revision)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1vq9s3n0mdgx2w84bjdsqxp3vcasfb824agjy56713902li1g8vm"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/latex/tabto")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source")
+ target) #t))))
+ (home-page "https://ctan.org/pkg/tabto-ltx")
+ (synopsis "``Tab'' to a measured position in the line")
+ (description
+ "This package provides @code{\\tabto{<length>}}, which moves the
+typesetting position to @code{<length>} from the left margin of the paragraph.
+If the typesetting position is already further along, @code{\\tabto} starts a
+new line; the command @code{\\tabto*} will move position backwards if
+necessary, so that previous text may be overwritten. In addition, the command
+@code{\\TabPositions} may be used to define a set of tabbing positions, after
+which the command @code{\\tab} advances typesetting position to the next
+defined ``tab stop''.")
+ (license license:lppl1.3+)))