summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 15:11:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:35 +0200
commitca948a85ed5ac3c988d860c2220af9583e1ad150 (patch)
treea2a5b847a605b615e384dbaa534f24d0dea70908
parente764edcbd068eeb7ba223bbcb87f55efa0850f8f (diff)
gnu: Add texlive-plantuml.
* gnu/packages/tex.scm (texlive-plantuml): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a3674f06a3..6abf65eeb7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11920,6 +11920,28 @@ positioning (the grid may be disabled, for final copy using the command
\\placeatsetup).")
(license license:lppl1.3+)))
+(define-public texlive-plantuml
+ (package
+ (name "texlive-plantuml")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/plantuml/"
+ "tex/lualatex/plantuml/")
+ (base32
+ "00ram4dm1n7v9xd50xhvp1jxih4y431sq05snqaxj292ib0yh5b8")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/plantuml")
+ (synopsis
+ "Support for rendering UML diagrams using syntax and tool of PlantUML")
+ (description
+ "The package provides support for rendering UML diagrams using the syntax
+and tools of PlantUML. The PlantUML syntax is very short and thus enables
+quickly specifying UML diagrams. Using @command{dot}, PlantUML layouts the
+diagrams.")
+ (license license:lppl1.3c)))
+
(define-public texlive-koma-script
(package
(name "texlive-koma-script")