summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2022-10-25 11:49:38 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-11-26 13:48:26 +0100
commitca98b3ab26b0a6f8024e35a7a9c23b896fd26b8c (patch)
tree9774757eda77554c2043e33dacb252ca9402b5e4
parent5ccb5837ccfb39af4e3e6399a0124997a187beb1 (diff)
gnu: gst-plugins-bad: Skip elements/camerabin test on some systems.
It seems to frequently fail on i686-linux and aarch64-linux. * gnu/packages/gstreamer.scm (gst-plugins-bad)[arguments]: Skip the elements/camerabin test on i686-linux and aarch64-linux. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/gstreamer.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index a92588a9e2..e46bf7b741 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -791,6 +791,14 @@ model to base your own plug-in on, here it is.")
;; FIXME: Why is this failing.
((".*elements/dash_mpd\\.c.*") "")
+ ;; This test is flaky on at least some architectures.
+ ;; https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1244
+ #$@(if (member (%current-system)
+ '("i686-linux" "aarch64-linux"))
+ `((("'elements/camerabin\\.c'\\]\\],")
+ "'elements/camerabin.c'], true, ],"))
+ '())
+
;; These tests are flaky and occasionally time out:
;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/932
((".*elements/curlhttpsrc\\.c.*") "")