summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-06-14 19:06:32 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-06-14 19:08:36 +0300
commitcb902d7e1bcddd6f4223d0c90b134e4728ac2295 (patch)
tree8747bda900f304d0c5859da86b40e46ad9d685ab
parent4e60cbe5bbcf425442952de0e8eb6410e9304d1d (diff)
gnu: onedrive: Link to all necessary libraries.
Reported by adanska on IRC. * gnu/packages/sync.scm (onedrive)[arguments]: Remove custom 'link-to-external-libraries phase to allow linking to more libraries.
-rw-r--r--gnu/packages/sync.scm4
1 files changed, 0 insertions, 4 deletions
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 75cd67fd2d..bd9fbab386 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -392,10 +392,6 @@ silently and reliably flow across to every other.")
#~(list (string-append "CC=" #$(cc-for-target)))
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'link-to-external-libraries
- (lambda _
- ;; Only link necessary libraries.
- (setenv "DCFLAGS" "-L--as-needed")))
(add-after 'configure 'adjust-makefile
(lambda _
(substitute* "Makefile"