summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWiktor Żelazny <wz@freeshell.de>2022-07-12 12:13:46 +0200
committerLudovic Courtès <ludo@gnu.org>2022-07-19 23:08:02 +0200
commitcba0bc29423d9d78dcf355a09f5df1391089d2ce (patch)
tree38e1a08a11fe8240f1322004ea89036d7517fa88
parenta8f1abec7fb5f1a4b35cfa7b6fb5f0754bdfdf12 (diff)
gnu: Add texlive-babel-danish.
* gnu/packages/tex.scm (texlive-babel-danish): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8ef9e1cb6e..ddcd0043c4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11055,3 +11055,30 @@ settings to typeset Finnish documents.")
Norwegian in @code{babel}. Some shortcuts are defined, as well as translations
to Norsk of standard “LaTeX names”.")
(license license:lppl1.3+)))
+
+(define-public texlive-babel-danish
+ (let ((template (simple-texlive-package
+ "texlive-babel-danish"
+ (list "/source/generic/babel-danish/")
+ (base32
+ "00dryb078fqckqjnxa2riq478j6d5i28j5cclv4bw7dn5naa3lz7"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ '())
+ "generic/babel-danish")
+ ((#:build-targets _ '())
+ ''("danish.ins")) ; TODO: use dtx and build documentation
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "source/generic/babel-danish")))))))
+ (home-page "https://www.ctan.org/pkg/babel-danish")
+ (synopsis "Babel support for Danish")
+ (description
+ "This package provides the language definition file for support of
+Danish in @code{babel}. It provides all the necessary macros, definitions and
+settings to typeset Danish documents.")
+ (license license:lppl1.3c+))))