summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 10:10:29 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:48 +0300
commitcc54d4b6e2addd437aea70dd47632191cfb98645 (patch)
treeb98b00980196515e2f08e425c95e8605116cfee6
parente5ff6dc3f390c190552c7d3e71aa490dc8c5434b (diff)
gnu: julia-gumbo-jll: Move to (gnu packages julia-jll).
* gnu/packages/julia-xyz.scm (julia-gumbo-jll): Move to ... * gnu/packages/julia-jll.scm: ... here.
-rw-r--r--gnu/packages/julia-jll.scm42
-rw-r--r--gnu/packages/julia-xyz.scm42
2 files changed, 42 insertions, 42 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 8b6ef39c43..062e504034 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -26,7 +26,8 @@
#:use-module (guix build-system julia)
#:use-module (gnu packages)
#:use-module (gnu packages gcc)
- #:use-module (gnu packages julia))
+ #:use-module (gnu packages julia)
+ #:use-module (gnu packages web))
;;; TODO: Remove this autogenerated source package
;;; and build it from realse source using <https://github.com/JuliaPackaging/Yggdrasil/>
@@ -73,6 +74,45 @@ originating @code{build_tarballs.jl} script can be found on the community
build tree Yggdrasil.")
(license license:expat)))
+(define-public julia-gumbo-jll
+ (package
+ (name "julia-gumbo-jll")
+ (version "0.10.1+1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Gumbo_jll.jl")
+ (commit (string-append "Gumbo-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00a182x5hfpjzyvrxdn8wh4h67q899p5dzqp19a5s22si4g41k76"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((gumbo (string-append (assoc-ref inputs "gumbo-parser"))))
+ (for-each
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("(const libgumbo = )\"(.*)\"" all const libname)
+ (string-append const "\"" gumbo "/lib/" libname "\"\n"))
+ (("(global artifact_dir =).*" all m)
+ (string-append m " \"" gumbo "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$"))))))))
+ (inputs
+ `(("gumbo-parser" ,gumbo-parser)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Gumbo_jll.jl")
+ (synopsis "Gumbo HTML parsing library wrappers")
+ (description "This package provides a wrapper for Gumbo HTML parsing library.")
+ (license license:expat)))
+
(define-public julia-jllwrappers
(package
(name "julia-jllwrappers")
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 35f7bd8d3f..49439ae0a2 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -28,8 +28,7 @@
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages julia-jll)
#:use-module (gnu packages maths)
- #:use-module (gnu packages tls)
- #:use-module (gnu packages web))
+ #:use-module (gnu packages tls))
(define-public julia-abstractffts
(package
@@ -762,45 +761,6 @@ differentiation (AD).")
library for parsing HTML.")
(license license:expat)))
-(define-public julia-gumbo-jll
- (package
- (name "julia-gumbo-jll")
- (version "0.10.1+1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/JuliaBinaryWrappers/Gumbo_jll.jl")
- (commit (string-append "Gumbo-v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "00a182x5hfpjzyvrxdn8wh4h67q899p5dzqp19a5s22si4g41k76"))))
- (build-system julia-build-system)
- (arguments
- '(#:tests? #f ; no runtests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((gumbo (string-append (assoc-ref inputs "gumbo-parser"))))
- (for-each
- (lambda (wrapper)
- (substitute* wrapper
- (("(const libgumbo = )\"(.*)\"" all const libname)
- (string-append const "\"" gumbo "/lib/" libname "\"\n"))
- (("(global artifact_dir =).*" all m)
- (string-append m " \"" gumbo "\""))))
- ;; There's a Julia file for each platform, override them all
- (find-files "src/wrappers/" "\\.jl$"))))))))
- (inputs
- `(("gumbo-parser" ,gumbo-parser)))
- (propagated-inputs
- `(("julia-jllwrappers" ,julia-jllwrappers)))
- (home-page "https://github.com/JuliaBinaryWrappers/Gumbo_jll.jl")
- (synopsis "Gumbo HTML parsing library wrappers")
- (description "This package provides a wrapper for Gumbo HTML parsing library.")
- (license license:expat)))
-
(define-public julia-http
(package
(name "julia-http")