summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-02-15 10:09:23 +0000
committerKei Kebreau <kei@openmailbox.org>2017-04-08 12:40:11 -0400
commitccda56886625af84d34ebf1f26b22345e5dbe235 (patch)
treea4ebf78bbc39e0abc89fe63eb7f93d2fe44f0634
parentd2b51c08fdf646822e038c520302af8e98583adf (diff)
gnu: Add python-openid.
* gnu/packages/python.scm (python-openid): New variable. Signed-off-by: Kei Kebreau <kei@openmailbox.org>
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0746af24a1..875908505c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5549,6 +5549,32 @@ for clients and servers.")
for clients and servers.")
(license license:asl2.0)))
+;; This is named "python3-openid" upstream, but python-python3-openid
+;; is too much of an tautology.
+(define-public python-openid
+ (package
+ (name "python-openid")
+ (version "3.0.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python3-openid" version))
+ (sha256
+ (base32
+ "1x3nh3fycqfn43jp5j5pb4q4y2jxp4mdka4absaa3bc0078qd758"))))
+ (propagated-inputs
+ `(("python-defusedxml" ,python-defusedxml)))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)))
+ (build-system python-build-system)
+ (home-page "https://github.com/necaris/python3-openid")
+ (synopsis "OpenID support for modern servers and consumers")
+ (description
+ "This library provides OpenID authentication for Python, both
+for clients and servers. This package provides the Python 3 port
+of python-openid.")
+ (license license:asl2.0)))
+
(define-public python-urwidtrees
(package
(name "python-urwidtrees")