summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-03 16:20:22 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-20 15:55:18 -0400
commitcec4f5f556246dd48c89234d635f0a7124f57a55 (patch)
tree71e12e9d645dbf44dca43b2ceac3ff4b80da9bb3
parent13953f0e7ec230e701faa679bcf2c1d6a3ab4693 (diff)
gnu: guile-lib: Update to 0.2.7.
* gnu/packages/guile-xyz.scm (guile-lib): Remove trailing #t. [source]: Remove snippet and modules field. [phases]{patch-for-cross-compilation}: Remove phase. [native-inputs]: Add pkg-config.
-rw-r--r--gnu/packages/guile-xyz.scm41
1 files changed, 6 insertions, 35 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index d89b9954de..9f4118f083 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -16,7 +16,7 @@
;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2017, 2018, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2018, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018, 2019, 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
@@ -2192,46 +2192,19 @@ library.")
(define-public guile-lib
(package
(name "guile-lib")
- (version "0.2.6.1")
+ (version "0.2.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/guile-lib/guile-lib-"
version ".tar.gz"))
(sha256
(base32
- "0aizxdif5dpch9cvs8zz5g8ds5s4xhfnwza2il5ji7fv2h7ks7bd"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Work around miscompilation on Guile 3.0.0 at -O2:
- ;; <https://bugs.gnu.org/39251>.
- (substitute* "src/md5.scm"
- (("\\(define f-ash ash\\)")
- "(define f-ash (@ (guile) ash))\n")
- (("\\(define f-add \\+\\)")
- "(define f-add (@ (guile) +))\n"))
- #t))))
+ "1ph4z4a64m75in36pdb4dw63dzdq3hdgh16gq33q460jby23pvz4"))))
(build-system gnu-build-system)
(arguments
- '(#:make-flags
- '("GUILE_AUTO_COMPILE=0") ; to prevent guild errors
+ '(#:make-flags '("GUILE_AUTO_COMPILE=0") ;placate guild warnings
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-for-cross-compilation
- (lambda _
- (substitute* "configure.ac"
- (("GUILE_FLAGS")
- "GUILE_FLAGS
-if test \"$cross_compiling\" != no; then
- GUILE_TARGET=\"--target=$host_alias\"
- AC_SUBST([GUILE_TARGET])
-fi
-"))
- (substitute* "am/guile.mk"
- (("guild compile") "guild compile $(GUILE_TARGET)"))
- (delete-file "configure") ; trigger the bootstrap phase to run
- ; autoreconf
- #t))
(add-before 'configure 'patch-module-dir
(lambda _
(substitute* "src/Makefile.in"
@@ -2239,8 +2212,7 @@ fi
"moddir = $(datadir)/guile/site/@GUILE_EFFECTIVE_VERSION@\n")
(("^godir = ([[:graph:]]+)")
"godir = \
-$(libdir)/guile/@GUILE_EFFECTIVE_VERSION@/site-ccache\n"))
- #t)))))
+$(libdir)/guile/@GUILE_EFFECTIVE_VERSION@/site-ccache\n")))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -2248,7 +2220,7 @@ $(libdir)/guile/@GUILE_EFFECTIVE_VERSION@/site-ccache\n"))
("guile" ,guile-3.0)
("pkg-config" ,pkg-config)))
(inputs
- `(("guile" ,guile-3.0)))
+ `(("guile" ,guile-3.0))) ;for cross-compilation
(home-page "https://www.nongnu.org/guile-lib/")
(synopsis "Collection of useful Guile Scheme modules")
(description
@@ -2256,7 +2228,6 @@ $(libdir)/guile/@GUILE_EFFECTIVE_VERSION@/site-ccache\n"))
modules, allowing for people to cooperate integrating their generic Guile
modules into a coherent library. Think \"a down-scaled, limited-scope CPAN
for Guile\".")
-
;; The whole is under GPLv3+, but some modules are under laxer
;; distribution terms such as LGPL and public domain. See `COPYING' for
;; details.