summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew James Kraai <kraai@ftbfs.org>2022-10-14 06:37:01 -0700
committerChristopher Baines <mail@cbaines.net>2022-10-16 18:24:26 +0100
commitcf19228932eff2ede5f39f4fdc759374e3b89991 (patch)
treee7a55c90860f7f423bea4a86d32658d08fdda29c
parentc3e103129d1fac8460e4e01e46749a0a72248ead (diff)
gnu: Add s3cmd.
* gnu/packages/python-xyz.scm (s3cmd): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ad9204e461..ebc56bbc11 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -75,7 +75,7 @@
;;; Copyright © 2020 Josh Marshall <joshua.r.marshall.1991@gmail.com>
;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;; Copyright © 2020 Alex ter Weele <alex.ter.weele@gmail.com>
-;;; Copyright © 2020 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2020, 2022 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2020 Yuval Kogman <nothingmuch@woobling.org>
@@ -16214,6 +16214,33 @@ modules, which are different and were developed separately, both serve
the same purpose: to provide Python bindings for libmagic.")
(license license:expat)))
+(define-public s3cmd
+ (package
+ (name "s3cmd")
+ (version "2.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/s3tools/s3cmd")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rdgwwmmp8mdxc84bxq6k9a7v7z2qgc3df47djzs2b84gw81dglx"))))
+ (build-system python-build-system)
+ (inputs
+ (list python-dateutil
+ python-magic))
+ (home-page "https://s3tools.org/s3cmd")
+ (synopsis "Command line tool for S3-compatible storage services")
+ (description
+ "S3cmd is a command line tool for uploading, retrieving and managing data
+in storage services that are compatible with the Amazon Simple Storage
+Service (S3) protocol, including S3 itself. It supports rsync-like backup,
+GnuPG encryption, and more. It also supports management of Amazon's
+CloudFront content delivery network.")
+ (license license:gpl2+)))
+
(define-public python-pkgconfig
(package
(name "python-pkgconfig")