summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-22 22:24:17 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-27 23:05:15 +0000
commitcf5c8c49021f7a4280d9e9dd99cacb50a0106742 (patch)
treecf1789117979871b748ceaf349fe0ae5aaa6e117
parentb58717b4191c06f029a3ae537b7f0421d74367b2 (diff)
gnu: clipman: Simplify package.
* gnu/packages/xdisorg.scm (clipman): [phases] <#:phases>: Adjust 'patch phase to relay on provided module import path. [inputs]: Remove go-github-com-alecthomas-kingpin; add go-gopkg-in-alecthomas-kingpin-v2. Change-Id: I3d9d82af29672ff94cdbd39b18ec4ed61b8e485f
-rw-r--r--gnu/packages/xdisorg.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 044d7c341b..8d3fd446ee 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3240,15 +3240,13 @@ After selection, the clip is put onto the PRIMARY and CLIPBOARD X selections.")
(add-before 'build 'patch
(lambda _
(substitute* "src/github.com/yory8/clipman/main.go"
- (("gopkg.in/alecthomas/kingpin.v2")
- "github.com/alecthomas/kingpin")
(("\"wl-copy\"")
(string-append "\"" (which "wl-copy") "\"")))))
(delete 'install-license-files))))
(native-inputs (list go-github-com-alecthomas-template
go-github-com-alecthomas-units))
(inputs (list go-github-com-kballard-go-shellquote
- go-github-com-alecthomas-kingpin
+ go-gopkg-in-alecthomas-kingpin-v2
libnotify
wl-clipboard))
(synopsis "Basic clipboard manager with support for persisting copy buffers")