summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-11-12 22:55:12 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2022-11-15 11:22:29 +0100
commitd244282b698087bb6f6cf3c1c4d57b7a5e2e8ffa (patch)
tree1e4e67df7ef7af4fda7d669b61d43e050951ef8b
parent3d09c03ea8b44efccd3a00c44e0ffb2bf72dcad2 (diff)
gnu: Add cl-gss.
* gnu/packages/lisp-xyz.scm (ecl-cl-gss, cl-gss, sbcl-cl-gss): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 4e2654a2d3..b647c1aa3d 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -88,6 +88,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages kerberos)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libffi)
#:use-module (gnu packages linux)
@@ -6287,6 +6288,52 @@ uses @code{uiop:run-program} as a backend.")
(define-public cl-inferior-shell
(sbcl-package->cl-source-package sbcl-inferior-shell))
+(define-public sbcl-cl-gss
+ (let ((commit "60086f4fd3b82316352e7f2288edbd58f03e08c5")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-gss")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lokedhs/cl-gss")
+ (commit commit)))
+ (file-name (git-file-name "cl-gss" version))
+ (sha256
+ (base32 "0zhxxn3zarird255s9i56bz0fm6dkv00mn8bbsjrhskg3wpcg4pb"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-gss-lib-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/functions.lisp"
+ (("libgssapi_krb5.so")
+ (search-input-file inputs "/lib/libgssapi_krb5.so"))))))))
+ (inputs
+ (list mit-krb5
+ sbcl-cffi
+ sbcl-trivial-garbage
+ sbcl-trivial-utf-8))
+ (home-page "https://github.com/lokedhs/cl-gss")
+ (synopsis "Common Lisp CFFI bindings to Generic Security Service (GSS)")
+ (description
+ "This package provides Common Lisp bindings to GSSAPI, which is
+designed to provide a standard API to authentication services. The API itself
+is generic, and the system can provide different underlying implementations.
+The most common one is Kerberos, which has several implementations, the most
+common of which is probably Active Directory.")
+ (license license:bsd-3))))
+
+(define-public ecl-cl-gss
+ (sbcl-package->ecl-package sbcl-cl-gss))
+
+(define-public cl-gss
+ (sbcl-package->cl-source-package sbcl-cl-gss))
+
(define-public sbcl-trivial-utf-8
(let ((commit "4d427cfbb1c452436a0efb71c3205c9da67f718f")
(revision "1"))