summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-24 14:54:58 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-24 15:34:03 +0100
commitd40c00c0f13ea8c715da093f3b36193baa2959e0 (patch)
tree0ac45cf898fccdbf429b14d14f4913bf6ffa3f89
parent3ddf722de3e404ae0e325900edbcfbf1e01ac7be (diff)
gnu: go-github-com-ipfs-go-cid: Adjust inputs.
* gnu/packages/ipfs.scm (go-github-com-ipfs-go-cid): Adjust inputs. [propagated-inputs]: Remove indirect golang modules go-github-com-gxed-hashland-keccakpg, go-github-com-minio-blake2b-simd, go-github-com-minio-sha256-simd, go-github-com-mr-tron-base58, go-github-com-multiformats-go-base32, go-github-com-multiformats-go-base36, go-github-com-spaolacci-murmur3, and go-golang-org-x-crypto. Change-Id: I0272c5e7ff335cb0b60eb2c56e55cb993519376c
-rw-r--r--gnu/packages/ipfs.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 02678a6b96..bcf6fea133 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -57,17 +57,10 @@
(list
#:go go-1.21
#:import-path "github.com/ipfs/go-cid"))
- (propagated-inputs (list go-github-com-gxed-hashland-keccakpg
- go-github-com-minio-blake2b-simd
- go-github-com-minio-sha256-simd
- go-github-com-mr-tron-base58
- go-github-com-multiformats-go-base32
- go-github-com-multiformats-go-base36
- go-github-com-multiformats-go-multihash-0.2.3
- go-github-com-multiformats-go-multibase
- go-github-com-multiformats-go-varint
- go-github-com-spaolacci-murmur3
- go-golang-org-x-crypto))
+ (propagated-inputs
+ (list go-github-com-multiformats-go-multihash-0.2.3
+ go-github-com-multiformats-go-multibase
+ go-github-com-multiformats-go-varint))
(home-page "https://github.com/ipfs/go-cid")
(synopsis "Content ID v1 implemented in Go")
(description