summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-09 10:02:02 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-09 10:02:02 +0300
commitd418784dbdce5d920cb385665d26a5d8427f4cc9 (patch)
tree348783e5709ca2345f2e3893af7c8bcb83c039c1
parent23b9dadc1decd040713fb2a409a9d4384e225135 (diff)
gnu: python-docopt: Honor #:tests? in check phase.
* gnu/packages/python-xyz.scm (python-docopt)[arguments]: In custom 'check phase honor #:tests?.
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0890792c03..95245ec0af 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11572,7 +11572,9 @@ automatically detect a wide range of file encodings.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _ (invoke "py.test"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "py.test")))))))
(home-page "http://docopt.org")
(synopsis "Command-line interface description language for Python")
(description "This library allows the user to define a command-line