summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-05 18:25:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-06 15:02:21 +0100
commitd4846779715ff77ccb35476a669bda34a291a1ab (patch)
treecc36d555be002f5e789b8e1f5031831231e634b0
parenta08801e205e0800c60e99743d9d47fe76a3a3aee (diff)
gnu: ghc-http-types: Run tests.
* gnu/packages/haskell-web.scm (ghc-http-types)[arguments]: Run tests. [native-inputs]: Add ghc-doctest, ghc-hspec, ghc-quickcheck, ghc-quickcheck-instances, and hspec-discover.
-rw-r--r--gnu/packages/haskell-web.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index fb7e27048b..c295477e2f 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -107,9 +107,12 @@ for screen-scraping.")
(base32
"08w30rf1i7kbh2j1iajqmj6yhhmglnb8kjggc8kdni3xahhrgcss"))))
(build-system haskell-build-system)
- (arguments `(#:tests? #f)) ; FIXME: Tests cannot find
- ; Blaze.Bytestring.Builder, which should be
- ; provided by ghc-blaze-builder.
+ (native-inputs
+ `(("ghc-doctest" ,ghc-doctest)
+ ("ghc-hspec" ,ghc-hspec)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-quickcheck-instances" ,ghc-quickcheck-instances)
+ ("hspec-discover" ,hspec-discover)))
(inputs
`(("ghc-case-insensitive" ,ghc-case-insensitive)
("ghc-blaze-builder" ,ghc-blaze-builder)