summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2023-02-20 16:04:58 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-02-23 15:25:39 +0100
commitd53e46cabfb176950162b36f7334bf36aa142b36 (patch)
tree397743bf6b71cf313c60390b6531e9698f4a0c96
parent83108a60e77fc97962e98f7db9a78ab85846c879 (diff)
gnu: Add texlive-catchfile.
* gnu/packages/tex.scm (texlive-catchfile): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dafed9d3c3..efccba17cc 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5304,6 +5304,26 @@ capabilities of longtable and tabularx; an environment for including plain TeX
in LaTeX documents; a jiffy to create slashed characters for physicists.")
(license license:lppl)))
+(define-public texlive-catchfile
+ (let ((template (simple-texlive-package
+ "texlive-catchfile"
+ (list "/doc/latex/catchfile/"
+ "/source/latex/catchfile/"
+ "/tex/generic/catchfile/")
+ (base32
+ "1dpxy64hs0bjp8d2dmikflc995vazf7fi6z92w51fnj2fidgl8gx"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t)
+ "latex/catchfile")))
+ (home-page "https://ctan.org/macros/latex/contrib/catchfile")
+ (synopsis "Catch an external file into a macro")
+ (description
+ "Catchfile catches the contents of a file and puts it in a macro.")
+ (license license:lppl1.3+))))
+
(define-public texlive-doi
(package
(inherit (simple-texlive-package