summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornafkhamdc <navid.afkhami@mdc-berlin.de>2024-03-28 12:29:59 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-03-28 13:37:20 +0100
commitd616e85ac8a380d5126da3184f7037c20866c884 (patch)
treefe2bd51dcc3d0214293b256b9808bee8ff7900e0
parentfb9549164520ad993c2fbbaedc899844d57baabc (diff)
gnu: python-upsetplot: Update to 0.9.0.
* gnu/packages/python-science.scm (python-upsetplot): Update to 0.9.0. [source]: Remove obsolete snippet. [arguments]: Remove custom check phase. [build-system]: Use pyproject-build-system. Change-Id: I68bcd6840577a12594e491e9fd5e114f9261f6c7 Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/python-science.scm22
1 files changed, 3 insertions, 19 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index b6a116f16b..b00dd9455d 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1435,31 +1435,15 @@ for handling arrays and scalars with units,respectively")
(define-public python-upsetplot
(package
(name "python-upsetplot")
- (version "0.6.0")
+ (version "0.9.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "UpSetPlot" version))
(sha256
(base32
- "11zrykwnb00w5spx4mnsnm0f9gwrphdczainpmwkyyi50vipaa2l"))
- (modules '((guix build utils)))
- (snippet
- ;; Patch for compatibility with newer setuptools:
- ;; https://github.com/jnothman/UpSetPlot/pull/178
- '(substitute* "upsetplot/data.py"
- (("import distutils")
- "from distutils.version import LooseVersion")
- (("if distutils\\.version\\.LooseVersion")
- "if LooseVersion")))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-v" "--doctest-modules")))))))
+ "14l5gcj88cclkj1mf74bcy1pxq1hgsiy27fa3vxrsk32ik1nmdwm"))))
+ (build-system pyproject-build-system)
(propagated-inputs
(list python-matplotlib python-pandas))
(native-inputs