summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZ572 <873216071@qq.com>2023-06-06 09:20:50 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-06-06 09:22:46 +0300
commitd6ae80c74200216fe7615739896fc1c6eacf7e7d (patch)
tree7826b56d8a63c27347aab12b4aa387be84ebd59e
parent8937898af9433c0b7a8d95a78c95e21576ae22e8 (diff)
gnu: thc-ipv6: Do not build with "-march=native".
* gnu/packages/networking.scm (thc-ipv6)[origin]: Add 'snippet'. [properties]: New field. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/networking.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 9dfc785f04..2055ed93c7 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -59,6 +59,7 @@
;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3097,7 +3098,10 @@ The filters can be aggregated and exported in the most common formats.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "07kwika1zdq62s5p5z94xznm77dxjxdg8k0hrg7wygz50151nzmx"))))
+ (base32 "07kwika1zdq62s5p5z94xznm77dxjxdg8k0hrg7wygz50151nzmx"))
+ (modules '((guix build utils)))
+ (snippet '(begin (substitute* '("Makefile")
+ (("-march=native") ""))))))
(build-system gnu-build-system)
(arguments
(list
@@ -3126,6 +3130,7 @@ The filters can be aggregated and exported in the most common formats.")
libpcap
openssl
perl))
+ (properties '((tunable? . #t)))
(home-page "https://github.com/vanhauser-thc/thc-ipv6")
(synopsis "IPv6 security research toolkit")
(description "The THC IPv6 Toolkit provides command-line tools and a library