summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:26:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:49 +0200
commitd87cb08dd3594bcf4bad5a0d3579fcbd90f99b1c (patch)
tree3b62dba74a3916ea3218de0f54cde6ba7cb9e6a0
parent1e9bf77acc382cb8b64e651af31ef301db6f27df (diff)
gnu: Add texlive-texfot.
* gnu/packages/tex.scm (texlive-texfot): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 49e38e051c..b03c3417e5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6434,6 +6434,29 @@ definition capability, new drawing commands can be constructed from drawing
segments.")
(license license:cc-by4.0)))
+(define-public texlive-texfot
+ (package
+ (name "texlive-texfot")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/texfot.1"
+ "doc/man/man1/texfot.man1.pdf"
+ "doc/support/texfot/" "scripts/texfot/")
+ (base32
+ "0cy1fz265ch13cn0jwfg7rlspqlxv8swnv6ljjvqqg8hbl390npd")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "texfot.pl")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/texfot")
+ (synopsis "Filter clutter from the output of a TeX run")
+ (description
+ "The package provides a small Perl script to filter the online output
+from a TeX run, attempting to show only those messages which probably deserve
+some change in the source. The TeX invocation itself need not change.")
+ (license license:public-domain)))
+
(define-public texlive-ticollege
(package
(name "texlive-ticollege")