summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-03-01 22:32:02 -0500
committerLeo Famulari <leo@famulari.name>2017-03-01 22:33:11 -0500
commitd8bcf080883ac72457bf099a936dc7b87b1ed421 (patch)
treeebb79bdaffda5f6466484b067ab97d789bb44f58
parentea9e58ef66f0fc0235eb1b36690ad4e41bf8771d (diff)
gnu: vdirsyncer: Update to 0.15.0.
* gnu/packages/dav.scm (vdirsyncer): Update to 0.15.0. [source]: Remove obsolete patch 'vdirsyncer-test-suite-slow-machines.patch'. * gnu/packages/patches/vdirsyncer-test-suite-slow-machines.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/dav.scm6
-rw-r--r--gnu/packages/patches/vdirsyncer-test-suite-slow-machines.patch42
3 files changed, 2 insertions, 47 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index f356a124b3..406e0dc963 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -953,7 +953,6 @@ dist_patch_DATA = \
%D%/packages/patches/util-linux-CVE-2017-2616.patch \
%D%/packages/patches/upower-builddir.patch \
%D%/packages/patches/valgrind-enable-arm.patch \
- %D%/packages/patches/vdirsyncer-test-suite-slow-machines.patch \
%D%/packages/patches/vim-CVE-2017-5953.patch \
%D%/packages/patches/vorbis-tools-CVE-2014-9638+CVE-2014-9639.patch \
%D%/packages/patches/vorbis-tools-CVE-2014-9640.patch \
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index 546597c617..7901e1c1d8 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -55,15 +55,13 @@ clients.")
(define-public vdirsyncer
(package
(name "vdirsyncer")
- (version "0.14.1")
+ (version "0.15.0")
(source (origin
(method url-fetch)
(uri (pypi-uri name version))
- (patches
- (search-patches "vdirsyncer-test-suite-slow-machines.patch"))
(sha256
(base32
- "044f01fjd8dpz4y9dm3qcc1a8cihcxxbr1sz6y6fkvglpb6k85y5"))))
+ "08aa5yxcj7ziz2r0hz4p554q8hgpfl2bh8r6r85f4g24mg6arxsj"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
diff --git a/gnu/packages/patches/vdirsyncer-test-suite-slow-machines.patch b/gnu/packages/patches/vdirsyncer-test-suite-slow-machines.patch
deleted file mode 100644
index 03093e8330..0000000000
--- a/gnu/packages/patches/vdirsyncer-test-suite-slow-machines.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-Fix test failures caused by some build machines running more slowly than
-expected, which manifest like this:
-
-------
-> raise FailedHealthCheck(message)
-E hypothesis.errors.FailedHealthCheck: Data generation is extremely slow: Only produced 4 valid examples in 1.08 seconds (1 invalid ones and 0 exceeded maximum size). Try decreasing size of the data you're generating (with e.g.average_size or max_leaves parameters).
-E See http://hypothesis.readthedocs.org/en/latest/healthchecks.html for more information about this. If you want to disable just this health check, add HealthCheck.too_slowto the suppress_health_check settings for this test.
-
-/gnu/store/b8d1r8bilvm3jkncgrpvmg3dni9cgcr1-python-hypothesis-3.1.0/lib/python3.5/site-packages/hypothesis/core.py:296: FailedHealthCheck
-------
-
-Patch copied from upstream source repository:
-
-https://github.com/pimutils/vdirsyncer/commit/10490a12f13f03495e0945eb9d45d7aed9ab0a6c
-
-From 10490a12f13f03495e0945eb9d45d7aed9ab0a6c Mon Sep 17 00:00:00 2001
-From: Markus Unterwaditzer <markus@unterwaditzer.net>
-Date: Sat, 18 Feb 2017 15:45:06 +0100
-Subject: [PATCH] Unconditionally disable HealthCheck.too_slow
-
----
- tests/conftest.py | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/tests/conftest.py b/tests/conftest.py
-index e0a07d5..3afd7cd 100644
---- a/tests/conftest.py
-+++ b/tests/conftest.py
-@@ -26,10 +26,12 @@ def benchmark():
- else:
- del pytest_benchmark
-
-+
-+settings.suppress_health_check = [HealthCheck.too_slow]
-+
- settings.register_profile("ci", settings(
- max_examples=1000,
- verbosity=Verbosity.verbose,
-- suppress_health_check=[HealthCheck.too_slow]
- ))
- settings.register_profile("deterministic", settings(
- derandomize=True,