summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2024-02-28 23:23:13 +0000
committerArun Isaac <arunisaac@systemreboot.net>2024-02-28 23:23:30 +0000
commitdacc31c44259f392048810dcb8e05549f209cc3e (patch)
tree90726fc94a59ab6d04a998ce6a1694343e502984
parent23283c50e96d7812a42b1272329fa3ba05a5a6e6 (diff)
gnu: python-jmespath: Update to 1.0.1.
* gnu/packages/python-xyz.scm (python-jmespath): Update to 1.0.1. [native-inputs]: Remove python-nose. Add python-pytest. Change-Id: If5df9541f34fb656f461a10da8df02a3dd101741
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0abd25df07..9ff8979853 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29,7 +29,7 @@
;;; Copyright © 2016-2023 Marius Bakke <marius@gnu.org>
;;; Copyright © 2016, 2017, 2021, 2022 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2016, 2017, 2019 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2016–2018, 2021–2023 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016–2018, 2021–2024 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016, 2017, 2018, 2020, 2021 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2016–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
@@ -18020,17 +18020,17 @@ that deprecated code is eventually removed.")
(define-public python-jmespath
(package
(name "python-jmespath")
- (version "1.0.0")
+ (version "1.0.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "jmespath" version))
(sha256
(base32
- "0pmzfi230zfgiq2rz896kbb9f7mp0lnrjdl6x1npvxfixn0f5454"))))
+ "1gpdc1f0q5c9scmbw1l9g40jjfk3pxwg91ayvn7xbvvddlh1n9lh"))))
(build-system python-build-system)
(native-inputs
- (list python-nose))
+ (list python-pytest))
(synopsis "JSON Matching Expressions")
(description "JMESPath (pronounced “james path”) is a Python library that
allows one to declaratively specify how to extract elements from a JSON