summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-05-27 13:53:11 -0400
committerLeo Famulari <leo@famulari.name>2020-05-27 15:03:03 -0400
commitdb38840198a62e84e0754975dfece75132fd6672 (patch)
tree7e6d72d4d25a881af1d6dead363bba2f65e9e6c0
parentffd2696bd8c898cb69b8b443db5584d84986d419 (diff)
Revert some Go package updates.
This reverts commit 5f833e0495f00a72f8d34a63e8afbc531afdd22d through 681ac9a66c26d2c739e41f03228f8c63fc0df482. It's not idiomatic to update Go packages independently of their users. This reversion was approved by Efraim on #guix: http://logs.guix.gnu.org/guix/2020-05-26.log * gnu/packages/golang.scm, gnu/packages/syncthing.scm, gnu/packages/tls.scm: Revert.
-rw-r--r--gnu/packages/golang.scm100
-rw-r--r--gnu/packages/syncthing.scm184
-rw-r--r--gnu/packages/tls.scm42
3 files changed, 166 insertions, 160 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e11c52b0e4..8dd276562a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -978,26 +978,28 @@ optimized for performance yet simple to use.")
(license license:expat))))
(define-public go-github-com-blang-semver
- (package
- (name "go-github-com-blang-semver")
- (version "4.0.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/blang/semver.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "14h9ys4n4kx9cbj42lkdf4i5k3nkll6sd62jcvl7cs565v6fiknz"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/blang/semver"))
- (home-page "https://github.com/blang/semver")
- (synopsis "Semantic versioning library written in Go")
- (description "Semver is a library for Semantic versioning written in Go.")
- (license license:expat)))
+ (let ((commit "60ec3488bfea7cca02b021d106d9911120d25fe9")
+ (revision "0"))
+ (package
+ (name "go-github-com-blang-semver")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/blang/semver.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19pli07y5592g4dyjyj0jq5rn548vc3fz0qg3624vm1j5828p1c2"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/blang/semver"))
+ (home-page "https://github.com/blang/semver")
+ (synopsis "Semantic versioning library written in Go")
+ (description "Semver is a library for Semantic versioning written in Go.")
+ (license license:expat))))
(define-public go-github-com-emicklei-go-restful
(let ((commit "89ef8af493ab468a45a42bb0d89a06fccdd2fb22")
@@ -2341,31 +2343,29 @@ statistics for wrapped connections.")
(license license:expat))))
(define-public go-github-com-mitchellh-go-homedir
- (package
- (name "go-github-com-mitchellh-go-homedir")
- (version "1.1.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mitchellh/go-homedir.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0ydzkipf28hwj2bfxqmwlww47khyk6d152xax4bnyh60f4lq3nx1"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/mitchellh/go-homedir"
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'set-home-directory
- (lambda _
- (setenv "HOME" "/")
- #t)))))
- (home-page "https://github.com/mitchellh/go-homedir")
- (synopsis "Go library for detecting and expanding the user's home directory without cgo")
- (description "This is a Go library for detecting the user's home
+ (let ((commit "ae18d6b8b3205b561c79e8e5f69bff09736185f4")
+ (revision "0"))
+ (package
+ (name "go-github-com-mitchellh-go-homedir")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mitchellh/go-homedir.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0f0z0aa4wivk4z1y503dmnw0k0g0g403dly8i4q263gfshs82sbq"))))
+ (build-system go-build-system)
+ (arguments
+ (quote (#:import-path "github.com/mitchellh/go-homedir"
+ ;; TODO: Tests fail because it tries to access home.
+ #:tests? #f)))
+ (home-page "https://github.com/mitchellh/go-homedir")
+ (synopsis "Go library for detecting and expanding the user's home directory without cgo")
+ (description "This is a Go library for detecting the user's home
directory without the use of @command{cgo}, so the library can be used in
cross-compilation environments.
@@ -2379,7 +2379,7 @@ package cannot cross compile. But 99% of the time the use for
@command{os/user} is just to retrieve the home directory, which we can do for
the current user without cgo. This library does that, enabling
cross-compilation.")
- (license license:expat)))
+ (license license:expat))))
(define-public go-github-com-multiformats-go-multiaddr
(let ((commit "fe1c46f8be5af4aff4db286e08839295bd922efb")
@@ -2824,7 +2824,7 @@ format in Go.")
(define-public go-github-com-kr-text
(package
(name "go-github-com-kr-text")
- (version "0.2.0")
+ (version "0.1.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2833,7 +2833,7 @@ format in Go.")
(file-name (git-file-name name version))
(sha256
(base32
- "0hf58ypz6rxsw6nx3i856whir9lvy4sdx946wbw1nfaf2rdmr9vx"))))
+ "1gm5bsl01apvc84bw06hasawyqm4q84vx1pm32wr9jnd7a8vjgj1"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/kr/text"))
@@ -3191,7 +3191,7 @@ error handling primitives in Go.")
(define-public go-github-com-maruel-panicparse
(package
(name "go-github-com-maruel-panicparse")
- (version "1.4.1")
+ (version "1.3.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3200,7 +3200,7 @@ error handling primitives in Go.")
(file-name (git-file-name name version))
(sha256
(base32
- "0sff44kqmpwzpa6h84fssdsv9glfm8bjjcnspsr64qzmqxpbc7m4"))))
+ "13qkn7f64yln8jdmma37h6ra4c7anxkp3vfgvfyb6lb07dpr1ibq"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/maruel/panicparse"))
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index bb264df717..99bdd7704b 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -232,7 +232,7 @@ configuration that is stored in a Go struct.")
(revision "0"))
(package
(name "go-github-com-bkaradzic-go-lz4")
- (version (git-version "1.0.0" revision commit))
+ (version (git-version "0.0.0" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -416,7 +416,7 @@ address of the default LAN gateway.")
(define-public go-github-com-lib-pq
(package
(name "go-github-com-lib-pq")
- (version "1.5.2")
+ (version "1.2.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -425,7 +425,7 @@ address of the default LAN gateway.")
(file-name (git-file-name name version))
(sha256
(base32
- "1wjw5pfjgc63n9934mgvg8hr1v9381mcdz62jkn9xqxqcv6b95lw"))))
+ "08j1smm6rassdssdks4yh9aspa1dv1g5nvwimmknspvhx8a7waqz"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/lib/pq"
@@ -468,7 +468,7 @@ GeoLite2 and GeoIP2 databases in Go.")
(define-public go-github-com-oschwald-maxminddb-golang
(package
(name "go-github-com-oschwald-maxminddb-golang")
- (version "1.6.0")
+ (version "1.4.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -477,7 +477,7 @@ GeoLite2 and GeoIP2 databases in Go.")
(file-name (git-file-name name version))
(sha256
(base32
- "1xdqaazxddnajh0qic1c70skad44kxxr7m46fypbnawn61v3f7gc"))))
+ "100wd5qv00pkcm6cb8c4x5gavc9jnn7drh6xrqh85hzci4rils66"))))
(build-system go-build-system)
(propagated-inputs
`(("go-golang-org-x-sys" ,go-golang-org-x-sys)))
@@ -492,25 +492,27 @@ higher-level API for doing so.")
(license isc)))
(define-public go-github-com-stathat-go
- (package
- (name "go-github-com-stathat-go")
- (version "1.0.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/stathat/go")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1zzlsl24dyr202qkr2pay22m6d0gb7ssms77wgdx0r0clgm7dihw"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/stathat/go"))
- (synopsis "Post statistics to StatHat")
- (description "This is a Go package for posting to a StatHat account.")
- (home-page "https://github.com/stathat/go")
- (license expat)))
+ (let ((commit "74669b9f388d9d788c97399a0824adbfee78400e")
+ (revision "0"))
+ (package
+ (name "go-github-com-stathat-go")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stathat/go")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zzlsl24dyr202qkr2pay22m6d0gb7ssms77wgdx0r0clgm7dihw"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/stathat/go"))
+ (synopsis "Post statistics to StatHat")
+ (description "This is a Go package for posting to a StatHat account.")
+ (home-page "https://github.com/stathat/go")
+ (license expat))))
(define-public go-github-com-rcrowley-go-metrics
(let ((commit "cac0b30c2563378d434b5af411844adff8e32960")
@@ -747,28 +749,30 @@ notification library in Go.")
(license expat))))
(define-public go-github-com-beorn7-perks-quantile
- (package
- (name "go-github-com-beorn7-perks-quantile")
- (version "1.0.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/beorn7/perks.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "17n4yygjxa6p499dj3yaqzfww2g7528165cl13haj97hlx94dgl7"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/beorn7/perks/quantile"
- #:unpack-path "github.com/beorn7/perks"))
- (synopsis "Compute approximate quantiles over an unbounded data stream")
- (description "Perks contains the Go package @code{quantile} that computes
+ (let ((commit "4c0e84591b9aa9e6dcfdf3e020114cd81f89d5f9")
+ (revision "0"))
+ (package
+ (name "go-github-com-beorn7-perks-quantile")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/beorn7/perks.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hrybsql68xw57brzj805xx2mghydpdiysv3gbhr7f5wlxj2514y"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/beorn7/perks/quantile"
+ #:unpack-path "github.com/beorn7/perks"))
+ (synopsis "Compute approximate quantiles over an unbounded data stream")
+ (description "Perks contains the Go package @code{quantile} that computes
approximate quantiles over an unbounded data stream within low memory and CPU
bounds.")
- (home-page "https://github.com/beorn7/perks")
- (license expat)))
+ (home-page "https://github.com/beorn7/perks")
+ (license expat))))
(define-public go-github-com-prometheus-client-model
(let ((commit "14fe0d1b01d4d5fc031dd4bec1823bd3ebbe8016")
@@ -876,31 +880,29 @@ Prometheus metrics.")
(license asl2.0)))
(define-public go-github-com-prometheus-procfs
- (package
- (name "go-github-com-prometheus-procfs")
- (version "0.0.11")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/prometheus/procfs.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1msc8bfywsmrgr2ryqjdqwkxiz1ll08r3qgvaka2507z1wpcpj2c"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/prometheus/procfs"
- ;; The tests require Go modules, which are not yet supported in Guix's
- ;; Go build system.
- #:tests? #f))
- (propagated-inputs
- `(("go-golang-org-x-sys" ,go-golang-org-x-sys)))
- (synopsis "Go library for reading @file{/proc}")
- (description "The @code{procfs} Go package provides functions to retrieve
+ (package
+ (name "go-github-com-prometheus-procfs")
+ (version "0.0.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/prometheus/procfs.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1z5jq5rjala0a0di4nwk1rai0z9f73qwqj6mgcbpjbg2qknlb544"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/prometheus/procfs"
+ ;; The tests require Go modules, which are not yet supported in Guix's
+ ;; Go build system.
+ #:tests? #f))
+ (synopsis "Go library for reading @file{/proc}")
+ (description "The @code{procfs} Go package provides functions to retrieve
system, kernel, and process metrics from the @file{/proc} pseudo file system.")
- (home-page "https://github.com/prometheus/procfs")
- (license asl2.0)))
+ (home-page "https://github.com/prometheus/procfs")
+ (license asl2.0)))
(define-public go-github-com-prometheus-client-golang
(package
@@ -943,7 +945,7 @@ server tools for Prometheus metrics.")
(define-public go-github-com-go-asn1-ber-asn1-ber
(package
(name "go-github-com-go-asn1-ber-asn1-ber")
- (version "1.4.1")
+ (version "1.3.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -952,7 +954,7 @@ server tools for Prometheus metrics.")
(file-name (git-file-name name version))
(sha256
(base32
- "0d7yl1f7ak0djkflw8wx1wlhym2whg7bh57m419arfym9ncwrhg1"))))
+ "0dxfmgk84fn0p6pz3i0cspynh6rly5pfk9wghm1q07mx99npln02"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/go-asn1-ber/asn1-ber"))
@@ -1035,27 +1037,29 @@ virtual connections from a single physical connection.")
(license expat)))
(define-public go-github-com-ccding-go-stun
- (package
- (name "go-github-com-ccding-go-stun")
- (version "0.1.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ccding/go-stun.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "133r2s4h9vv5lmjd680my2c5973gfi0gg5cxcwzjwdjad83a2dm0"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/ccding/go-stun"))
- (synopsis "STUN client implementation")
- (description "Go-stun is a go implementation of the STUN client (RFC 3489
+ (let ((commit "be486d185f3dfcb2dbf8429332da50a0da7f95a6")
+ (revision "2"))
+ (package
+ (name "go-github-com-ccding-go-stun")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ccding/go-stun.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1gr0rw1c1y7wh6913lyn5k4ig023by27i36bly6am8dwgrgp34ww"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/ccding/go-stun"))
+ (synopsis "STUN client implementation")
+ (description "Go-stun is a go implementation of the STUN client (RFC 3489
and RFC 5389).")
- (home-page "https://github.com/ccding/go-stun")
- (license asl2.0)))
+ (home-page "https://github.com/ccding/go-stun")
+ (license asl2.0))))
(define-public go-github-com-cespare-xxhash
(package
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index f6746ebe21..ec81b7bf07 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017, 2018 Nikita <nikita@n0.is>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
@@ -1021,23 +1021,25 @@ relatively simple Bash script.")
(license license:expat)))
(define-public go-github-com-certifi-gocertifi
- (package
- (name "go-github-com-certifi-gocertifi")
- (version "2020.02.11")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/certifi/gocertifi")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "018bsy1vclsdk2kns9f37giabibg3kggk3vpj0yr3dv0k72gzybk"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/certifi/gocertifi"))
- (synopsis "X.509 TLS root certificate bundle for Go")
- (description "This package is a Go language X.509 TLS root certificate bundle,
+ (let ((commit "a5e0173ced670013bfb649c7e806bc9529c986ec")
+ (revision "1"))
+ (package
+ (name "go-github-com-certifi-gocertifi")
+ (version (git-version "2018.01.18" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/certifi/gocertifi")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1n9drccl3q1rr8wg3nf60slkf1lgsmz5ahifrglbdrc6har3rryj"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/certifi/gocertifi"))
+ (synopsis "X.509 TLS root certificate bundle for Go")
+ (description "This package is a Go language X.509 TLS root certificate bundle,
derived from Mozilla's collection.")
- (home-page "https://certifi.io")
- (license license:mpl2.0)))
+ (home-page "https://certifi.io")
+ (license license:mpl2.0))))