summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-15 17:28:12 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-16 12:44:37 +0100
commitdc1719cba4a92777a6e71000c6ee5cd75c82070c (patch)
tree5236e4be1a447ece0fe4d4fa660cf105986ef7ed
parent579b35ddd1aad7e008b97e98f903d628be668dd2 (diff)
gnu: python-astroml: Make compatible with recent Matplot and Scipy.
* gnu/packages/astronomy.scm (python-astroml)[arguments]: Add phases 'matplotlib-compatibility and 'scipy-compatibility. Change-Id: Id88cf769f705f9326f41f951403583155bcee58f
-rw-r--r--gnu/packages/astronomy.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 4f019cb765..1e2c3f8caa 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -572,6 +572,17 @@ Main features:
;; Do not test examples
(("testspaths = astroML doc examples")
"testspaths = astroML"))))
+ (add-after 'unpack 'matplotlib-compatibility
+ (lambda _
+ (substitute* "astroML/plotting/tools.py"
+ (("^( *)ax.(lines|patches|tables|artists|images).clear.*" _ indent type)
+ (string-append indent "for art in ax." type ":\n"
+ indent " art.remove()\n")))))
+ ;; See commit e1c779de1f0ce4cb499dbda6c23d14f76b98e430
+ (add-after 'unpack 'scipy-compatibility
+ (lambda _
+ (substitute* "astroML/dimensionality/iterative_pca.py"
+ (("sym_pos=True") "assume_a=\"pos\""))))
(add-before 'check 'pre-check
;; Some tests need this
(lambda _